Pfr_unroute_kentry delete failed



  • Pfsense 2.1.5

    We have 2 pfsense boxes using CARP.
    One wan gateway.

    The slave box will freeze up and the error: pfr_unroute_kentry delete failed is on the console.

    I did search for this but I am not sure how to fix it, it’s a bit unclear to me exactly whats the problem.
    It seems that one of the suggestions was to turn off the gateway monitoring?
    But honestly I am not sure I understand exactly.

    Does someone has any info they could share so we can get this working?



  • Nobody?



  • You running BGP or OSPF on there? It's an unusual circumstance, but that's the only scenario I can think of where that can happen. It's something that's fixed in the base OS in 2.2.



  • Not running either BGP or OSPF.

    It has happened 3 times in the last month and a half I think.

    This is on a test system with low load, no more then 5mb of internet traffic going to 2 servers.
    Xeon L5335 cpu and 8gb of memory.



  • Any large tables (aliases/pfblocker) on there?



  • We have pfblocker on there.
    We only had pfblocker with the top spam countries listed and no other lists when it failed the first time.

    We have the following packages:
    Arpwatch
    Autoconfigbackup
    bandwidthd
    Snort
    Postfix
    Mail scanner
    nrpe v2
    openvpn client export utility
    pfblocker



  • pfblocker is definitely the cause in that circumstance. I believe that to be fixed already in 2.2.



  • Thank you very much for taking the time to respond.

    Will disable pfblocker and see how it goes.