Something wrong with the serial speeds of the memstick-serial image



  • I just tried to do a mSATA installation from a 32bit memstick-serial from 7 november.
    The furtest I've got was the installation screen, but it's impossible to install.

    The Soekris net6501 does not handle a serial speed of 115200 very well. Barely usable as a lot of keystrokes are not properly recognized.
    What's even worse is that the memstick-serial boots with some unknown serial speed, and at some point moves to a 115200 serial speed.
    But even if I set the ConSpeed of the net6501 to 115200, and watch all the random characters fly across the Putty screen, I most of the time can't even press "I" to do a installation.

    The one time I did manage to have a I pressed the installation screen was so messed up, and as most keystrokes aren't recognized properly, I could not even get past the first screen.

    From the net6501 doc page to install pfSense using a USB stick, it's mentioned that it uses the default FreeBSD serial speed of 9600.
    Well, memstick-serial sure isn't nor does it auto-detect the serial speec of the machine booting from.

    Am I missing anything here?

    I read something about a installation of 2.1.5 and then updating to 2.2.
    Going to try that for now as this won't work for me at the moment.



  • I was able to do a installation of 2.1.5 using it's memstick-serial image and then update to the latest 2.2 beta version.
    But still, the initial serial console speed is totally messed up. This is up to the point it starts booting FreeBSD itself (or at least that is what I believe it does then).

    And there is no console after:

    Starting CRON… done.
    pfSense (pfSense) 2.2-BETA i386 Fri Nov 07 09:27:21 CST 2014
    Bootup complete

    Meaning no menu. But I won't be needing that soon again I hope.



  • Sigh. Nevermind the blank console after booting.
    Somehow (ID-10T error) I must have unchecked the Serial Terminal option to enable the frist serial port.


  • Rebel Alliance Developer Netgate

    FYI- The initial console serial setup was changed in such a way that it should carry over from the BIOS at whatever speed it had been using as far as the slice selection, otherwise it may not have been visible.

    On 2.2 after that point it would be 115200 all around. Set your BIOS to 115200 and it should be OK.

    I have used 115200 on my net6501 for quite some time and it's been fine in PuTTY, SecureCRT, screen, and tip/cu



  • I have tried setting ConSpeed to 115200 but hat change anything for me.
    In fact, it almost looks like my net6501 doesn't like that speed too much.
    Lot of characters are different, and input wasn't working properly either.

    Almost like a Local Echo problem of sorts.
    The boot shows like bbbboooottttiiiinnnnggg.
    Not sure what to make of it…

    If you want, I can try to record it?


  • Rebel Alliance Developer Netgate

    The duplication is likely from the BIOS doing VGA->serial redirection. Usually it's harmless and disappears once it gets past boot0



  • Think it does. Will need to check myself again.
    Been switching speed so much that I can't remember.


Log in to reply