Pfsense.com packages system seems to be down… or is it my eyes?



  • Hey,

    Correct me if I'm wrong, but my server seems to be telling me in no uncertain terms, that yes, it can contact the pfsense.com servers, and is getting a reply that the packages system is b0rked up. I tried to install a package and it did some weird crap, running through the process like it was installing the package but mixing in things like it was unable to load, or something, yet continuing to "completion"… I went back to notice a big banner across the top of the packages list saying it couldn't contact the pfsense.com package list.

    Curious, I dig into the pfSense PHP code and trace it back through pkg-utils.inc, which calls call_pfsense_method(), which in turn sets up a PHP-XMLRPC connection to pfsense.com. I saw the line saying "log_error(...)" and went into my system log to find several recent entries of:
    "php: /pkg_mgr.php: XMLRPC request failed with error 2: Invalid return payload: enable debugging to examine incoming payload"
    So, curious about what "enable debugging" meant (reading the code, obviously that wasn't pfSense talking, it was the XMLRPC code talking), I Googled "invalid return payload...". I found a clue about $cli -> setdebug(1) and reading the debug info. Now, I know a plenty about PHP, but I build whole sites around procedural code since PHP is a scripting language, not an object oriented language... so I was half clueless there. But other things I read said to set it before sending information, so I throw it in after the object is "initialized" (I guess where $cli is created), but before the command is sent.

    I get the following output now, when I run the get_pkg_info (if I remember correctly) code, with parameters added, from the "execute commands" interface in pfSense:

    ---GOT---
    HTTP/1.1 200 OK
    Date: Mon, 25 Feb 2008 11:46:10 GMT
    Server: Apache/1.3.37 (Unix) PHP/4.4.7 with Suhosin-Patch
    X-Powered-By: PHP/4.4.7
    Connection: close
    Content-Type: text/html
    
    XML error: No pfsensepkgs object found!
    
    ---END---
    

    That, coming off the pfSense servers. So… who blew what up?  ???



  • I just upgraded to version 1.2 and I have the same problem…



  • @Falcon4:

    So… who blew what up?  ???

    Possibly the guys that just do the web site update of www.pfsense.com?
    I would consider this an update glitch while doing all the other stuff. Be patient!



  • Hello all, i'm new user of pfsense, i installed yersterday pfsense 1.2-RC4 and i can't see packages. Unable to communicate to pfSense.com. Please check DNS, default gateway, etc. In the log php:
    "/pkg_mgr.php: XMLRPC request failed with error 2: Invalid return payload: enable debugging to examine incoming payload"
    I can't ping now pfsense.com , but yesterday yes, and i can navigate to other part.
    I see a localization in italian, but now i can't find it, where is it?
    First i work with IPCOP an i try pfsense for packages!!! LOL

    Thanks
    Overflow75



  • Be patient!

    The web site is being updated at the moment and things like the package system might fail.
    I'm sure someone is working on this already…



  • Still dont work  :'(



  • It's being worked on.  Be patient while the guys figure out what happened.



  • It has to do with the site move to the new website. Please be patient. Once this final issue is solved (which is a problem of the site that is hosting the packages and not the package manager of the firewall) we'll make you all happy  ;)



  • Its up again =)



  • Whoa, shit… I opened the flood gates. Hard to believe I actually posted something right for once. =)

    Thanks for the info!  ;D



  • Sorry, I hosed the packages in the process of moving the website. Working again now.


Locked