Rede interna não acessa nosso IP externo apenas quem está fora (falta algo)



  • Olá Pessoal,
    Tudo bem?

    Nossos servidores estão tudo atrás do pfsense com NAT para acessa-los.

    Por exemplo: Um IP fixo (válido) da internet no Pfsense, configurado uma NAT para cada server com IP interno e sua porta usada, ou seja:

    IP fixo pfsense: 200.x.x.x:7474  com Nat para 10.1.x.x:7474
                                200.x.x.x:21      com Nat para 10.1.1:21  e assim por diante.

    Ok, para quem precisa acessar isso de fora de nossa rede interna, acessa tranquilamente, mas quem precisa de dentro de nossa rede (onde está o pfsense) ele não permite/encontra o que é desejado acessar.

    Alguém poderia indicar de que forma libero ou possa fazer com que seja possível acessar via IP fixo.
    Existe alguma regra?
    Estou meio perdido.
    Inclusive já troquei uma ideia com o provedor e já me adiantaram que não existe filtro nenhum da parte deles.

    Muito obrigado pela atenção

    Fiquem com Deus

    Douglas



  • Quem tenta acessar interno, tenta pelo ip: 10.1.x.x:7474 e 10.1.x.x:21 ??….ou estao tentando acessar pelo ip externo: 200.x.x.x:7474 ?
    Pois de dentro da sua rede tem que ser pelo ip interno, no pfsense na aba da lan tem que liberar as portas 21 e 7474 para esses ips



  • vai na regra do nat e olha o NAT reflection deixa use default system



  • olha tambem como ta la em system >> advanced  aba firewall/NAt a opção NAT Reflection mode for port forwards no meu ta enable (NAT + proxy) e ta funcionando normal tinha um web serve que ficava assim depois dessas configurações agora posso acessar pelo ip publico tanto de fora quando de dentro da rede, testa e da um retorno



  • @marcioducrato:

    olha tambem como ta la em system >> advanced  aba firewall/NAt a opção NAT Reflection mode for port forwards no meu ta enable (NAT + proxy) e ta funcionando normal tinha um web serve que ficava assim depois dessas configurações agora posso acessar pelo ip publico tanto de fora quando de dentro da rede, testa e da um retorno

    :)Nao tinha lembrado desse "detalhe", que permite acessar pelo ip externo da rede interna tambem.



  • @marcioducrato:

    olha tambem como ta la em system >> advanced  aba firewall/NAt a opção NAT Reflection mode for port forwards no meu ta enable (NAT + proxy) e ta funcionando normal tinha um web serve que ficava assim depois dessas configurações agora posso acessar pelo ip publico tanto de fora quando de dentro da rede, testa e da um retorno

    marcioducrato e todo mundo, boa tarde!

    A sua dica foi bater e valer, foi só marcar isso que você indicou e funcionou na hora!

    Obrigado pela atenção e ajuda, sua e de todos amigos.

    Um abraço

    Douglas



  • cara fico feliz em ajudar no que precisar estamos ai.



  • @marcioducrato:

    cara fico feliz em ajudar no que precisar estamos ai.

    Marcioducrarto, bom dia!

    Assim, parte da configuração deu certo sim, pelo menos no que se refere nosso serviço web deu certo porém, temos um ftp na NAT que não está respondendo se tentarmos conectar pela rede interna, ou seja:

    Se estivermos dentro da rede (onde o pfsense está) ao tentar fazer a conexão no ftp pelo ip público: ftp://200.x.x.x ele não responde porém, quem estiver fora acessa tranquilamente.

    Estranho que para um serviço ele liberou mas para outro não na configuração sugerida por você. Seŕá que ainda falta algo pra configurar?

    Muito obrigado pela ajuda e atenção!

    Douglas



  • num é porta bloqueada não, você já olhou se porta estar liberada por onde você estar tentando acessar, tipo se você estar tentando acessar de fora tem que liberar na porta wan



  • @marcioducrato:

    num é porta bloqueada não, você já olhou se porta estar liberada por onde você estar tentando acessar, tipo se você estar tentando acessar de fora tem que liberar na porta wan

    Pois então, acredito que a porta não está bloqueada porque qualquer pessoa de fora de nossa rede pode acessar o ftp com o ip público tranquilamente, se ele estivesse bloqueada acho que o usuário iria receber alguma mensagem… não foi possível conectar, ou erro ou qualquer coisa do genero que indique erro.

    A configuração que vc sugeriu funcionou para um serviço web de primeira aqui, só não o ftp

    Bom vou ficar pesquisando, mas agradeço sua ajuda por enquanto

    Obrigado

    Douglas



  • @marcioducrato:

    olha tambem como ta la em system >> advanced  aba firewall/NAt a opção NAT Reflection mode for port forwards no meu ta enable (NAT + proxy) e ta funcionando normal tinha um web serve que ficava assim depois dessas configurações agora posso acessar pelo ip publico tanto de fora quando de dentro da rede, testa e da um retorno

    Galera so para registar.
    Hoje estava com o mesmo problema no PFSense 2.1.5-RELEASE (i386)
    Tentei deixar a regra como nosso amigo marcioducrato mencionou (NAT + proxy), FUNCIONOU SEM PROBLEMAS porem nos LOG's do Firewall NÃO ESTAVA registrando os acesso.
    Acessos esses que estava partindo da minha REDE INTERNA (LAN) para o meu IP EXTERNO (WAN) e o serviço estava na REDE INTERNA (LAN).
    Entao deixei as configurações desta maneira

    System >> Advanced >> Firewall/NAT >> Opção NAT Reflection mode for port forwards "(Enable (Pure NAT))" e a opção Enable automatic outbound NAT for Reflection (Habilitada).

    Desta forma os acessos foram registrados nos LOG's do Firewall.
    abraço galera #ficaadica
    ;D



  • This post is deleted!