Dashboard not showing IPv4 DNS servers (NEVER MIND)



  • A dynamic IPv6 DNS server is showing on the dashboard (that's new).  However, none of the IPv4 DNS servers configured on the General tab are showing.

    Just started on:

    2.2-BETA (amd64)
    built on Wed Nov 12 02:14:25 CST 2014
    FreeBSD 10.1-RELEASE




  • What is in:
    /etc/resolv.conf

    The system information widget gets the data from that file, matching lines that have "nameserver" in them.

    Do you have "Allow DNS server list to be overridden by DHCP/PPP on WAN" checked?

    It might be overriding the IPv4 entries you specified with the IPv6 one it got dynamically. (Not sure how that is supposed to work mixing IPv4 and IPv6 static and dynamic DNS servers)



  • Interesting.  The IPv4 DNS server configured in General (see attached image) is not being picked up at all.

    /root: cat /etc/resolv.conf
    # Generated by resolvconf
    search localdomain
    nameserver 2601:a:2xxx:xx0:225:90ff:fef1:c230
    
    [2.2-BETA][root@pfsense_test.localdomain]/root:
    

    This is just a test box that I update daily and it just started ignoring the IPv4 DNS today.




  • What type of v6 connections do you have on that system?



  • v6 is SLACC.  Only the LAN is active (it's a test VM).  The dynamic IPv6 you see is the production pfSense LAN address.

    Until today's update, the IPv4 DNS server configured in General was in use and is the only one that showed up on the dashboard.



  • Self inflicted wound.

    Set a flag to daemonize dnscrypt-proxy and it spanked something else.

    WAS:  'dnscrypt_proxy_flags="-a 127.0.0.1:40"'
    CHANGED TO:  'dnscrypt_proxy_flags="-a 127.0.0.1:40 -d"'

    SORRY!!!!!