Cant reboot - ends with exec failure



  • Hello,
    today i wanted to reboot my pfs 2.1.5 (amd64) with installed snort, vnstat2  and active traffic shaper. But the system halts with mesage: trying to mount root from /dev/ad0s1a, waring: / was not properly dismounted, bad dir ino 23590 at offset 0: mangled entry and init: cant exec /bin/sh for /etc/rc: exec fromat error.

    i rebooted the system from gui, but it always ends there. any idea?


  • Netgate

    Sounds like you've got a hard drive problem.  You might need to boot from alternate media, force an fsck, and cross your fingers.  If you can get a copy of your /conf/config.xml file first that'd probably be a good move.



  • Hello,
    its a virtual machine. Is there a possibility to do it like that: 1. backup config with install packages 2. new install  3. restore config with packages ?? I am not firm with freebsd so what is the best way to check the filesystem else?


  • Netgate

    Boot the VM from an ISO I guess.  If you run it as a live CD you should be able to drop to the shell and get at the disk to fsck it, copy the config, etc.



  • Its an KVM virtualisation with qcow2 as disk format. so its an installation. i could choose some option in boot menu perhaps.


  • Netgate

    Sorry.  No idea.  Maybe someone else has worked with it.



  • Ok no problem an thanks for trying to help. Tried to ask on the virtualisation platform too.



  • Perhaps it is not clear but i could start from  a snapshot and pfs runs. i can connect to the console and could start the shell. any commands to check filesystem?
    edit: start shell and run fschk. Failure are found but not corrected ?!



  • Hi,
    i checked the virtual conainer and its ok. so i think it must a corruption in the filesystem of freebsd / pfsense. i boot into shell and run fsck, it found some error but could repair. i think while its the root. so i tried with option -f -y but no success. i also found a command to make it writeable, but it didnt work. my problem is i dont know freebsd. i think i have to boot from an cd and run fsck. the question is there a iso to download which works well for freebsd / pfsense? i also ask myself where the failure cames from. i simple update the pfsense and install snort, nothing more on the system or custom things. thx