*HEADS UP* - careful with upgrades - zf kernel load unexpected EOF



  • Ok guys…..i have zf kernel load unexpected EOF (end of file) after morning 15th snapshot! Whole week I load and install on cool down on every day basis new snapshots, sometimes even 2 or 3 per day.....and now I am stuck with unexpected EOF error when I try to boot up my 15th November morning snapshot. Is there anything I can do to fix that behavior or these is the DEAD END for my pfsense installation...?

    For now I just ended up with simple console I've tried to look further for any kernel.old file since upgrade procedure from WebGUI rebooted my box, but ls command just show me /boot/kernel/kernel and nothing else in /boot/kernel the output is clear and without nothing, simple ls on /boot/ directory gives me imagine that I have no way to recover from these state.

    If I miss something there and can deal with these kind of frustrating situation, like I previously did when upgrading from 2.1.5 to 2.2 writing some sort of things in /etc/fstab when pfsense lost mount point to my / (root) which is caused during upgrade procedure, write here and post some guideline for me please ;D Cause I am not familiar in such state of crashes, only figured out once how to add new ID and string to my fstab since upgrading to FreeBSD 10+.



  • same error here can post a pic if needed, had to re image… tried to rescue the config with a live cd and that would fail... used a slightly older back up ... was able to re-image and bring back up. tried upgrading again same issue. so using an older build right now



  • Nah, I am just installed 10.1 on ZFS partition, that's it…....trying to configure basic settings  ;D



  • Same here! Updated this morning and found out that it won't boot anymore.

    What can I do to rescue this install?





  • Just to report that nanoBSD is OK. I upgraded from:

    2.2-BETA (i386)
    built on Fri Nov 14 18:48:42 CST 2014
    FreeBSD 10.1-RELEASE
    

    to

    2.2-BETA (i386)
    built on Sat Nov 15 03:49:56 CST 2014
    FreeBSD 10.1-RELEASE
    

    without problem.



  • Same here. Things have gone so well with this Alpha/Beta that I didn't check the forums before upgrading.

    This version should be revoked.



  • Safe to update to amd64 built on Sat Nov 15 10:08:19 CST 2014?



  • I do not know, I updated to a 15th version can't remember the time.



  • I deleted all snapshot auto-updates. It's definitely a problem on both 32 and 64 bit full version. I probably should have left the nano images there, but they'll get re-populated.

    There is another build running right now that will probably have the same problem but I'm letting it run. I'll check that at some point after it comes out.

    Until someone says otherwise, don't upgrade anything other than test systems.



  • @Pertan:

    What can I do to rescue this install?

    Reinstall and restore backup. Rescue config in installer should work too, though I haven't tried that in a bit.



  • Smart advice that applies to lots of problems…  haha
    I usually get scolded for saying that.



  • There is a new snapshot up that doesn't seem to have that problem. I've upgraded upwards of a half dozen different full installs, mix of 32 and 64 bit, to the most recent snapshot at the time of this writing and they all went fine. I'm not sure what the issue was, and probably won't know until we can discuss on Monday. Take care when upgrading in the mean time.



  • @cmb:

    There is a new snapshot up that doesn't seem to have that problem.

    New version: Sun Nov 16 04:06:10 CST 2014

    "This image is not digitally signed."

    :(



  • Snapshots aren't signed, that's normal.



  • Sun Nov 16 04:06:10 CST 2014

    Installed and worked fine for me.



  • worked when upgraded this time, there was an error synching user profiles on first boot next boot no such error, took a third boot to check still was fine, checked config and users all seem to be fine, will be checking IPsec when remote in just over an hour. do not expect and issues

    tested IPsec works… seems everything is good now



  • I've upgraded about 10 systems to the 3 snapshots out since the run I deleted and haven't had any issues since, seems this is fine now.



  • @cmb:

    I'm not sure what the issue was, and probably won't know until we can discuss on Monday.

    Any further info on what the problem was?