2.2 Outgoing FTP

  • Hi,

    when i initiate a FTP connection from lan to external through pfsense, i can connect and change directory, but not for example do an "dir".
    I took a look at the running ruleset with "pfctl -sr" or take a look at /tmp/ruleset.debug, i cannot find any rule for ftp-proxy …

    Is there any trick or button i've forgotten?

    Any help?



  • Have you tried passive mode? After connecting, issue the command PASV.

  • Thats no choise.
    The Software which establishes the FTP connection has no option for changing active/passive.
    Just wonder why there are no rules loaded to PF for the ftp-proxy?

    Is there no way in the GUI to setup the rules like i would do in pf.conf (openBSD)?:

    anchor "ftp-proxy/*"


    Any tip from insiders?

  • We don't use ftp-proxy, there is a built-in in-kernel FTP proxy.

  • OK.

    230 Guest login ok, access restrictions apply.
    ftp> ls
    500 Illegal PORT rejected (address wrong).

Log in to reply