Can not get ipv4 voip to work. Tried nat forwarding to no avail.



  • Can not get ipv4 voip to work. Tried nat forwarding to no avail.

    I am on a pppoe link, currently only ipv4 seems to work.

    I can not get my voip phone to work.

    I tried nat forwarding, set up the rules in both directions.

    Any suggestions as how to get this working?

    The strange thing is even before rules were set the phone was able to register with my provider.

    I can not dial out.

    Seems I get no voip traffic over the link.

    When I use my old router with asuswrt-merlin it works out of the box.



  • Don't port forward if you just have a phone connecting to an outside PBX.

    Outside of that, read here:
    https://doc.pfsense.org/index.php/VoIP_Configuration



  • I already found this link but am not able to understand correctly what is written there.

    I could understand the parts with

    "Set Conservative state table optimization"

    and

    "Disable scrub".

    I installed siproxd but the  configuration is way to complicated to me.

    And I did not understand the part about

    "Disable source port rewriting".

    What I did was giving the Phone a static dhcp lease.

    Then I set up udp forwarding per the directions my provider is handing out.

    See:

    http://hilfe.telekom.de/hsp/cms/content/HSP/de/3378/FAQ/theme-45859561/Telefonie/theme-45859560/Anschluss-und-Tarife/theme-45859549/Telefonieren-und-Surfen/theme-82239611/IP-basierter-Anschluss/faq-350884716

    In short:

    UDP (out): Ports 5060, 30000-31000, 40000-41000, 3478, 3479
    UDP (in): Ports 5070, 5080, 30000-31000, 40000-41000
    TCP (out): Port 80, 443

    I only have one phone,
    so port forwarding should to the job.

    I still have not found how i could forward port ranges,
    if someone told my how to do this I would be glad.

    Because the wan voip adresses change frequently with my provider I can not use static adressing voip server wise.

    Any help would be appreciated.