Can’t Connect to Port 25



  • Hello,

    My setup consists of WAN LAN DMZ network.

    DMZ gateway: 172.16.0.1

    Web Server and Mail Server on same machine with NIC set as 172.16.0.2 and 172.16.0.3

    VIPs

    Address: xxx.xxx.xx.98/29
      Interface: DMZ
      Type: Alias
      Web Server

    Address: xxx.xxx.xx.99/29
      Interface: DMZ
      Type: Alias

    Address:  xxx.xxx.xx.100/29
      Interface: DMZ
      Type: Alias
      Mail Server

    NAT 1:1

    Interface: WAN
      External IP: xxx.xxx.xx.98 – Web Server
      Internal IP:  172.16.0.2

    Interface: WAN
      External IP: xxx.xxx.xx.99
      Internal IP: 172.16.0.3

    Interface: WAN
      External IP: xxx.xxx.xx.100 – Mail Server
      Internal IP: 172.16.0.4

    NAT Rules

    WAN TCP * * xxx.xxx.xx.100 25(SMTP) 172.16.0.4 SMTP(25)

    Firewall Rules

    TCP * * 172.16.0.4 25(SMTP) * None

    DMZ Rule

    TCP * * * 25(SMTP) * None

    I am unable to connect to port 25 using Telnet from localhost to my mail server but I’m able to connect to mail.vif.com and mail.hmailserver.com.
    Am I missing something? Any help would be much appreciated.

    Karl



  • Is the localhost you refer to on the same subnet as the email machine?  I use Hmail here and works great!

    edit- damn spellcheck!



  • I'm using telnet from the same host (machine) where my mail server resides which is hmailserver. The IP ranges on hmailserver is set at, lower IP = 127.0.0.0 and upper IP = 127.0.0.0
    I haven't changed any settings on hmailserver which is currently running fine using ISA 2006 firewall.



  • The firewall would have no affect on the local machine.  If you cant connect on a telnet client which resides on the same machine as Hmailserver then something is wrong on that machine.

    On the Hmail administrator screen-

    What are your settings for /settings/advanced/ipranges  both /my computer and /internet?

    Then under /TCP IP Ports-  all types should have an IP of 0.0.0.0

    Try mxtoolbox.com to test your incoming.



  • Here are my hmailserver settings and my results using mxtoolbox to connect to my mail server.