Windows 2012 não comunica com PFsense - RESOLVIDO!



  • Boa noite galera,

    Meu windows 2012 não comunica com o ip do pfsense e também não navega, mesmo colocando o dns do google no campo do dns do windows, porém, toda a minha rede funciona normalmente recebendo via dhcp do PFsense e navegando na net, apenas os 2 servidores win2012 que não navegam nem pingam para o pfsense. O curioso é que recebem o dhcp numa boa.

    Estou usando no windows 2012 o AD e o server DNS dele, no pfsense utilizo o bloqueio para Mac`s não cadastrados. Em DNS server coloquei o dns de um dos meus servidores win2012 e o outro do google. DNS forward está habilitado e em configurações gerais onde tem 4 espaços pra DNS configurei os 2 primeiros com o do google e os outros dois com o do meu win2012 e marquei a porta wan como gateway (ao lado dele). To cheio de dúvidas quanto a configuração correta do dns para trabalhar com o servidor de dados junto ao pfsense e em outro tópico que abri não ficou muito claro como configurar… se alguém tiver o cenário parecido e puder ajudar agradeço muito!
    Abraço e desculpem a "noobisse"! rsrs



  • Recomendo deixar o DHCP no windows com o AD, e os primeiros DNS do PFSense coloque os do Windows com AD também, porque se precisar de gerar relatórios do Squid fica mais fácil de gerar com os nomes das máquinas.

    Confere o Gateway dos servidores Windows, se estão apontando para o PFSense, pois se as estações estão navegando, estão recebendo o GW do PFSense. É provável que o GW dos Windows Server não estão apontando para o PFSense.



  • Então, o DHCP eu deixo no pfsense em função dele permitir que eu bloqueie dispositivos desconhecidos (o que pra minha rede aqui é vital), o gateway ta apontado certinho, inclusive o server recebe do pfsense o ip dele também (quando eu removo do estático) o que indica que ele está comunicando de alguma forma com o pfsense…



  • Certo, mas tenha em mente que pode ter problemas de DNS porque o DHCP no windows faz a associação automática.



  • Mas preciso de uma luz pq o server windows não navega de forma alguma… vi um tópico parecido que não tinha definição do que fazer... preciso resolver isso...



  • considerando que as definicoes de rede (gateway e dns-server, lembrando que tem que ser o ip do seu pfsense) estão corretas no seu server windows, como ele se conecta na internet? utliliza proxy no navegador ou liberação atravez do firewall? se for proxy, a configuracao foi inserida no navegador? se for firewall, a liberacao do ip foi feita?



  • isso que é o mais louco, o win2012 recebe o dhcp do pfsense, testei isso também, no pfsense liberei o ip dele e ainda botei pra passar fora do squid, as outras máquinas da rede ele enxerga e pinga tranquilamente, porém ele não pinga pro ip do pfsense, mesmo colocando um dns publico (google) de forma manual por exemplo ele não navega, mas, ao abrir as propriedades de rede ele ainda me da que ta com acesso a internet… o curioso é que todas as outras máquinas que possuo na rede conseguem navegar na internet e também acessar o servidor sem problema algum. Hoje fiz o teste de desabilitar o DNS-forward mas não resultou em nada... continua a mesma coisa... não pinga pro pfsense nem navega mas recebe dhcp numa boa e interage com todas as máquinas da rede normalmente.



  • Use o tcpdump na console para ver se os pacotes chegam no Pfsense  e veja também se o mac address  desses servidores não  estão  identicos.  Já vi placas xingling com mesmo mac.



  • Agora consegui resolver!! Marcelo, obrigado pela dica mas não era isso não… o problema era o seguinte: Eu havia deixado em configurações gerais o DNS do windows 2012 e havia indicado o gateway da minha wan… após alterar isso pra "none", ativei novamente o dns-forwarder que havia desabilitado e testei… pra minha felicidade o problema parou de acontecer e meu servidor pingou normalmente para o pfsense!

    Obrigado aos que me ajudaram e espero que isso sirva para outros que venham a cometer o mesmo erro que eu cometi!! Ainda bem que existe esse fórum pois estou sempre aprendendo com vocês! vlw!



  • Ola Pessoal.

    Vim comentar neste tópico porque estou com o problema bem parecido e ainda não consegui resolver.

    Meu windows server ele se comunica com o pfsense, ele pinga qualquer ip, pinga os endereços de sites, porém, não navega.

    Quando eu coloco outro gateway de outro firewall que tenho ele funciona normalmente.

    Não acredito que seja problema no pfsense porque toda a rede e ou outros servidores navegam normalmente. Até troquei o IP deste windows server 2012 por 1 IP que esta funcionando na rede e mesmo assim não navegou pelo pfsense.

    Pode até não ser problema no firewall, porém, como eu não sei mais o que fazer, vim aqui para pedir ajuda e se alguém tem alguma idéia se o windows pode bloquear um gateway.

    Já passei antivirus. O ip dele coloquei em outro computador e o outro navegou normalmente.

    Meu Pfsense tem o DHCP ativado, porém, o range dos meus servidores estão configurados com IP Fixo. O windows server não tem AD, nem DHCP nem o servidor DNS. Ele funciona apenas para o ERP da empesa.

    Agradeço qualquer ajuda