Virtual IP not working in 2.2 like it did in 2.1.5



  • I just setup 2.2 under Hyper-V on Server 2012 R2. Other than a single Virtual IP all working well.  I may well have made a mistake but it's escaping me now. I've compared and compared the 2.2. to a working instance of 2.5

    The virtual IP is just a second static IP on our WAN port that we forward to a second web server.

    The firewall logs do not seem to show any traffic when I issue a request (either web browser or nmap) against the Virtual IP. If I issue the same request against the main IP for the WAN port we see the traffic coming and an everything seems to work.

    Can someone give me some pointers on what else to look at other than the firewall log?

    Thank you much - Richard



  • OK - well that was an easy fix. It turned out to be the particular site I was testing from. On a hunch I tried from a different location and all is well.

    It happens that the site having the problem uses the same ISP as our office and is physically very close. I wonder if that it's associated?

    Anyway, sorry for the noise.

    • Richard


  • Thanks for coming back with the results.



  • Wouldn't be the first time I've seen connectivity issues between two customers on the same ISP, though it's pretty rare. Likely either a routing issue between them on the ISP's network for some reason, or maybe one end or the other is using a wrong subnet mask where that side thinks something is local that isn't.



  • I tried it this morning and it's working from that location now.

    Thank you for the ideas/explanation.