Constant newwanipv6: ip change detected



  • Hy,
    I got Pfsense up and running, but I get constant (every 5-6 seconds)

    "Nov 18 22:25:45 php: rc.newwanipv6: pfSense package system has detected an ip change -> x❌x❌:2 … Restarting packages."
    followed by:
    php: rc.newwanipv6: ROUTING: setting default route to
    php: rc.start_packages: Restarting/Starting all packages.
    php: rc.newwanipv6: Resyncing OpenVPN instances for interface WAN.

    I cant either connect Openvpn client via Pfsense, nor can the openvpn client on one of the pc´s on the nat side connect to openvpn, while pfsense is in the route. as soon as i connect the pc directly to the router openvpn runs fine on the pc client. while pfsense in in the route both vpn clients (pfsense and the pc´s openvpn client) show constant restarts because of timeout ( i assume cause the gateway is resetted).

    i know that my modem is using ds-lite and i really dont need no ipv6. i already disabled ipv6 dhcp on the wan interface, but didnt change a thing.

    so how can i get rid of this behaviour - maybe disable ipv6 on the wan? (by newly assigning wan interface in the shell?)

    thanks!!!!



  • What do your DHCP logs show for dhcp6c? Status>System logs, DHCP tab. Sounds like maybe it didn't shut itself off after being disabled. The logs might help determine the root of the issue so it can be fixed in 2.2 if it isn't already.

    A reboot likely will make it stop, though I'd like to see the logs before you reboot it.



  • hy, thanks for your answer, but i already rebooted, it works now, ipv6 dhcp resolution stopped. i have no more ipv6 messages in the dhcp log.



  • I was suffering high load on a 2.2.5 system that had DHCP6 enabled on a WAN interface.  It was working (ISP was TimeWarnerCable) but sometime in the middle of the night they decided to switch my modem from bridge mode to router/NAT mode and start handing out 192.168.0.2 to my WAN interface.  This broke DHCP6…

    Suddenly I saw high load on my pfSense (caused by dhcpd and unbound according to top) and clog -f /var/log/system showed this pattern over and over again every 1-2 seconds:

    Dec 14 11:52:42	php-fpm[30155]: /rc.newwanipv6: Removing static route for monitor 24.29.99.36 and adding a new route through 192.168.0.1
    Dec 14 11:52:42	php-fpm[30155]: /rc.newwanipv6: Removing static route for monitor 2607:f8b0:4006:807::1000 and adding a new route through fe80::8e09:f4ff:fe10:217
    Dec 14 11:52:42	php-fpm[30155]: /rc.newwanipv6: Removing static route for monitor 68.237.161.12 and adding a new route through 108.30.185.1
    Dec 14 11:52:42	php-fpm[30155]: /rc.newwanipv6: ROUTING: setting IPv6 default route to fe80::8e09:f4ff:fe10:217%igb2
    Dec 14 11:52:41	check_reload_status: Syncing firewall
    Dec 14 11:52:37	php-fpm[30155]: /rc.newwanipv6: rc.newwanipv6: on (IP address: 2604:2000:f10b:300:208:a2ff:fe09:9bd3) (interface: opt2) (real interface: igb2).
    Dec 14 11:52:37	php-fpm[30155]: /rc.newwanipv6: rc.newwanipv6: Info: starting on igb2.
    Dec 14 11:52:36	check_reload_status: Reloading filter
    Dec 14 11:52:36	php-fpm[98434]: /rc.newwanipv6: Removing static route for monitor 24.29.99.36 and adding a new route through 192.168.0.1
    Dec 14 11:52:36	php-fpm[98434]: /rc.newwanipv6: Removing static route for monitor 2607:f8b0:4006:807::1000 and adding a new route through fe80::8e09:f4ff:fe10:217
    Dec 14 11:52:36	php-fpm[98434]: /rc.newwanipv6: Removing static route for monitor 68.237.161.12 and adding a new route through 108.30.185.1
    Dec 14 11:52:36	php-fpm[98434]: /rc.newwanipv6: ROUTING: setting IPv6 default route to fe80::8e09:f4ff:fe10:217%igb2
    Dec 14 11:52:31	php-fpm[98434]: /rc.newwanipv6: rc.newwanipv6: on (IP address: 2604:2000:f10b:300:208:a2ff:fe09:9bd3) (interface: opt2) (real interface: igb2).
    Dec 14 11:52:31	php-fpm[98434]: /rc.newwanipv6: rc.newwanipv6: Info: starting on igb2.
    Dec 14 11:52:30	check_reload_status: Reloading filter
    Dec 14 11:52:30	php-fpm[67665]: /rc.newwanipv6: Removing static route for monitor 24.29.99.36 and adding a new route through 192.168.0.1
    Dec 14 11:52:30	php-fpm[67665]: /rc.newwanipv6: Removing static route for monitor 2607:f8b0:4006:807::1000 and adding a new route through fe80::8e09:f4ff:fe10:217
    Dec 14 11:52:30	php-fpm[67665]: /rc.newwanipv6: Removing static route for monitor 68.237.161.12 and adding a new route through 108.30.185.1
    Dec 14 11:52:30	php-fpm[67665]: /rc.newwanipv6: ROUTING: setting IPv6 default route to fe80::8e09:f4ff:fe10:217%igb2
    
    

    For now I just disabled that WAN interface completely which has caused things to settle.  Not sure why the lack of valid DHCP6 would cause the router to go into a tailspin though.


Log in to reply