Wierd issue with switch GS724T



  • So my old GS724T v3 switch just died  >:(

    Luckily I had a spare GS724T v2, so I plugged it in thinking I would be all up and running in no time. But no….

    When I plug a PC directly into the switch the releveant lights on the front light up as expected.
    But when I plug in the LAN interface from pfsense no light! There is no connection!

    The LAN interface is a static IP with "Enable DHCP server on LAN interface" enabled.
    Switch is reset to factory defaults.

    Heres what I have tried with no joy:

    • Multiple ports on the switch

    • Patch cable and cross over cables.

    • Having the switch obtain an IP address via DHCP and also set as a static IP on the same subnet as the LAN.

    Wierdly as I have mutliple interfaces I have tried my WIFI interface and that lights up a port as does my VLAN interfaces (althought the switch is not configured for these yet, just proving a connection is detected)

    I also have a dumb netgear switch spare which works fine with the same patch cable from the LAN interface.

    Any ideas why I can't get the switch to connect with pfsense?


  • Netgate Administrator

    What NIC hardware is your LAN interface?

    Steve



  • It's a firebox x1250 pfsense 2.1.5


  • Netgate Administrator

    No link lights at all implies some negotiation failure. You could try fixing the speed/duplex.
    Is the LAN on an sk or msk interface? Try swapping to the other type if you can.

    Steve



  • well my LAN was on sk0 and it works fine on budget FS108 switch, but not on this GS724T. As said in earlier post my WIFI interface on sk2 works fine.

    Swapping the interface to msk0 and it works fine. I have no clue what is going on here but at least I now have 24 ports and VLAN support.


  • Netgate Administrator

    I have found some combinations hardware that just won't work with no explanation. I have a laptop here that just won't link to my old faithful SMC switch but works fine with everything else I've tried. It's independent of OS so I think it must be a low level incompatibility somewhere. It's a Realtek NIC. Clearly one (or both) of those devices is not 100% standards compliant and I have found some edge case. If I put another switch in between it works fine.

    Steve