• Hi,

    I have enabled default gateway switching in Misc -> Advanced since 2.1. In my 2.1.5 setup it works fine, if WAN1 goes down, it switches to WAN2. If WAN1 comes back, it switches the default route back to WAN1 (I just verified this by restoring my old 2.1.5 KVM).
    With 2.2 this seems to have stopped working at some point in the betas. Bringing down WAN1 makes it switch to WAN2's default gateway. But it does never switch back when WAN1 comes back online. When I press Save/Apply on WAN1 I can force it to switch the default gateway back. But it won't do it on it's own anymore.
    Anyone else seeing this or is it just my setup?

    I'm on

    2.2-BETA (i386) 
    built on Sat Nov 22 02:14:01 CST 2014 
    FreeBSD 10.1-RELEASE
    

  • Did another test.
    -switched off WAN1 router
    -let it settle an switched WAN1 router back on
    -the default route stays with WAN2 like noted in my first post
    -switched off WAN2 router
    -let it settle
    -the default gateway is not switched back to WAN1 as I would expect, it stays with WAN2.

    The web GUI is really unresponsive during the test.

    And my gateway cannot send mails anymore:

    Nov 25 05:44:51 xxx.xxx.de php-fpm[14109]: /rc.dyndns.update: Could not send the message to xxx@xxx.de -- Error: could not connect to the host "smtp.1und1.de": ??
    
    

  • What gateway are you using with the filter rules? did you change it to the failover group?


  • My IPv4 LAN filter rules are configured to use a gateway group with Tier1 WAN1, Tier2 WAN2, Trigger Level: Member Down.


  • Still the same with

    2.2-BETA (i386) 
    built on Thu Nov 27 23:16:40 CST 2014 
    

    Nobody else using default gateway switching? I would also stop using it as my clients work fine with the gateway rules, but I guess the firewall itself will get into trouble when the default route is dead?
    I.e. mails are not sent out. And using unbound might also be problematic then. Haven't tested unbound without switching enabled yet, tough.

    Edit: unbound seems to work fine without gw switching. Maybe I'll just turn it off then, the mails are not that important to me. Worked with 2.1.5 in my configuration tough.


  • I think i found it.
    Please try a next coming snapshots.


  • This is looking really good now, thank you for fixing it Ermal!