Cannot set media/speed on PPPoE Connection



  • Background: I'm in Australia and have just switched from iiNet to Dodo (Both on NBN connections) as I've moved residence. I'm using a PCEngine APU and worked fine with iiNet who didn't require PPPoE, the NBN terminator device thing saw the NIC as full gigabit. I'm running pfSense 2.1.5-RELEASE.

    I'm trying to force my PPPoE connection to me 1000baseT <full-duplex>since the NBN termination device only thinks that the APU is running 10/100 and is thus slowing my full internet speed down.

    I've tried manually setting it in the config with something like this:

     <wan><if>pppoe0</if>
    	 <blockpriv><blockbogons><enable><media>1000baseT</media>
    	<mediaopt>full-duplex</mediaopt>
    	 <alias-address><alias-subnet>32</alias-subnet>
    	 <spoofmac><ipaddr>pppoe</ipaddr></spoofmac></alias-address></enable></blockbogons></blockpriv></wan> 
    

    However this doesn't seem to have taken any effect and I'm also unable to change the option through the GUI (There is no option for it)

    I know the NBN boxes can see the API as having a full 10/100 NIC as when I was at my previous residence it saw it no problem (The light on the NBN termination box changes colour when it has a 10/100 connection)

    Going to Status -> Interfaces doesn't show any setting for Media at all on this interface.

    Anyone got any advice as for what I can do?</full-duplex>


  • Netgate Administrator

    You can't set the media type on a PPPoE interface (or any type of virtual interface) you have to set it on the parent interface. If you don't have that available because it isn't assigned just add it as an new interface and set it as type 'none'. Then set the media type there.

    What is the actual hardware the WAN is connected to? Are you sure it's not forced to 100Mbps, have you tried connecting to it with something else?

    Steve