Installation of squidGuard-squid3 FAILED!



  • Beginning package installation for squidGuard-squid3 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squidGuard-squid3 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/squidguard-squid3-1.4_4-amd64.pbi ...  (extracting)
    ERROR: No digital signature! If you are SURE you trust this PBI, re-install with --no-checksig option.
    of squidguard-squid3-1.4_4-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for squidguard-squid3-1.4_4-amd64...done.
    Removing squidGuard-squid3 components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squidguard.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.



  • I am also having the same issue on i386 image

    Beginning package installation for squidGuard-squid3 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squidGuard-squid3 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/squidguard-squid3-1.4_4-i386.pbi ...  (extracting)
    ERROR: No digital signature! If you are SURE you trust this PBI, re-install with --no-checksig option.
    of squidguard-squid3-1.4_4-i386 failed!

    Installation aborted.Removing package...
    Starting package deletion for squidguard-squid3-1.4_4-i386...done.
    Removing squidGuard-squid3 components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squidguard.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.



  • You have to enable packages without signature authorization.

    I can't remember where it was, since I rollbacked to 2.1.5.
    But after that, it works.



  • Hope they resolve the issue for 2.2 as early as possible.


Log in to reply