Yet another can't boot from USB loser (on APU)



  • I am trying to boot pfSense from a USB thumb drive on  a new APU1D4 system, with the goal of installing on a mSATA SSD.

    I don't think I'm having a serial line speed issue, which seems to be the most common failure.

    I used "Win32 Disk Imager" to write the current memstick image onto a 8Gb thumb drive.  The image is "pfSense-memstick-2.1.5-RELEASE-amd64-20140825-0744.img"  I have tried 3 different thumb drives, a 4Gb Sony (actualy Kingston), some generic 8Gb stick, and an 8Gb PNY purchased today.

    I am able to boot from an SD card with the most recent nanoBSD image.  To see if the thumb drive was working, I booted from SD with the thumb drive inserted, mounted the the file system on the thumb drive, and did a "du -k" on it.  The output ended with

    
        222533  /mnt/test
    
    

    which is close to the what du on "/" produces. So that seems good.

    I am using PuTTY for the console.  The output from power up to hang is below.  It takes about 15 seconds.  Starting with the serial line at 9600 results is 15 seconds of garbled output, as expected,  and then nothing.

    The transcript ends with a "/", Actually one "/" is printed and then overprinted with another "/" about a second later.

    If I hit control-C a after the first "/" is printed but before the second, I get to the FreeBSD boot loader:

    
        FreeBSD/x86 boot
        Default: 0:ad(0,a)/boot/loader
    
    

    Once the second "/" is printed, the system no longer responds to the keyboard.

    Thanks very much for any help,

    Norman

    
    PC Engines APU BIOS build date: Apr  5 2014
    Reading data from file [bootorder]
    SeaBIOS (version ?-20140405_120742-frink)
    SeaBIOS (version ?-20140405_120742-frink)
    Found coreboot cbmem console @ df150400
    Found mainboard PC Engines APU
    Relocating init from 0x000e8e71 to 0xdf1065e0 (size 39259)
    Found CBFS header at 0xfffffb90
    found file "bootorder" in cbmem
    CPU Mhz=1001
    Found 27 PCI devices (max PCI bus is 05)
    Copying PIR from 0xdf160400 to 0x000f27a0
    Copying MPTABLE from 0xdf161400/df161410 to 0x000f25b0 with length 1ec
    Copying ACPI RSDP from 0xdf162400 to 0x000f2590
    Copying SMBIOS entry point from 0xdf16d800 to 0x000f2570
    Using pmtimer, ioport 0x808
    Scan for VGA option rom
    EHCI init on dev 00:12.2 (regs=0xf7f08420)
    Found 1 lpt ports
    Found 2 serial ports
    AHCI controller at 11.0, iobase f7f08000, irq 11
    EHCI init on dev 00:13.2 (regs=0xf7f08520)
    EHCI init on dev 00:16.2 (regs=0xf7f08620)
    Searching bootorder for: /rom@img/setup
    Searching bootorder for: /rom@img/memtest
    OHCI init on dev 00:12.0 (regs=0xf7f04000)
    OHCI init on dev 00:13.0 (regs=0xf7f05000)
    OHCI init on dev 00:14.5 (regs=0xf7f06000)
    OHCI init on dev 00:16.0 (regs=0xf7f07000)
    Searching bootorder for: /pci@i0cf8/usb@12,2/storage@1/*@0/*@0,0
    Searching bootorder for: /pci@i0cf8/usb@12,2/usb-*@1
    Searching bootorder for: /pci@i0cf8/usb@16,2/storage@1/*@0/*@0,0
    Searching bootorder for: /pci@i0cf8/usb@16,2/usb-*@1
    USB MSC vendor='Multiple' product='Card  Reader' rev='1.00' type=0 removable=1
    Device reports MEDIUM NOT PRESENT
    scsi_is_ready returned -1
    Unable to configure USB MSC drive.
    Unable to configure USB MSC device.
    USB MSC vendor='PNY' product='USB 2.0 FD' rev='1100' type=0 removable=1
    USB MSC blksize=512 sectors=15810560
    All threads complete.
    Scan for option roms
    Running option rom at c000:0003
    
    iPXE (http://ipxe.org) 00:00.0 C000 PCI2.10 PnP PMMpmm call arg1=1
    pmm call arg1=0
    +DF0F06C0pmm call arg1=1
    pmm call arg1=0
    +DF04C5C0 C000
    
    Searching bootorder for: /rom@genroms/pxeboot.rom
    
    Build date: Apr  5 2014
    System memory size: 4592 MB
    
    Press F12 for boot menu.
    
    Searching bootorder for: HALT
    drive 0x000f2520: PCHS=0/0/0 translation=lba LCHS=984/255/63 s=15810560
    Space available for UMB: c1000-ee800, f0000-f2520
    Returned 253952 bytes of ZoneHigh
    e820 map has 7 items:
      0: 0000000000000000 - 000000000009fc00 = 1 RAM
      1: 000000000009fc00 - 00000000000a0000 = 2 RESERVED
      2: 00000000000f0000 - 0000000000100000 = 2 RESERVED
      3: 0000000000100000 - 00000000df14e000 = 1 RAM
      4: 00000000df14e000 - 00000000e0000000 = 2 RESERVED
      5: 00000000f8000000 - 00000000f9000000 = 2 RESERVED
      6: 0000000100000000 - 000000011f000000 = 1 RAM
    enter handle_19:
      NULL
    Booting from Hard Disk…
    Booting from 0000:7c00
    /
    
    


  • UPDATE:  SOLVED

    First I tried updating the bios (build 9/8/2014), which involves booting TinyCore Linux on a  thumb drive, which I did with no trouble. (Still using Win32DiskImager)

    I was still unable to boot pfSense on a thumb drive.

    Then I tired writing the same pfSense image  to a new thumb drive using 'dd' on MacOS.  That finally worked.

    So the combination of my 5 year old desktop, its USB plumbing, Win32DiskImager, and certain memory sticks results in unbootable media.


Log in to reply