Yet Another Port Forward Issue with Owncloud



  • Just to preface, I am new to PFSense and networking, so go easy on me! I just need some advice on this one…

    I have read and watched all the tutorials and troubleshooting guides on the forum, Google and YouTube and I keep striking out.

    I "think" I know what's wrong but I am just not sure and I don't want to mess anything else up.

    So, here's the deal.

    The PFSense box is the default gateway for the Netgear router and PFSense's IP is 10.1.10.1

    The router is set to IP 10.1.10.2 with the rest of the LAN pointed to it's default 192.168.1.1 IP for the gateway.

    Everything is working really well except for the Owncloud box.

    OC is using the router as the default gateway because there is a port-forwarding rule set in the router.

    We can access OC all day long from within the LAN on it's local IP of 192.168.1.2 but I cannot get port forwarding to work on WAN.

    Outside the LAN...nothing.

    I have followed everyone's tutorials and pfsense's guide on port-forwarding.

    I guess my question is: Is the issue with the router being set as the default gateway? If so, what should I do?

    I have added an attachment with the LAN layout for your review. I can add some screenshots of my PFSENSE settings if needed.

    Thanks all!




  • It looks to me like you're using the Netgear as some kind of switch - presumably because it has multiple ports that you can plug your equipment into. In truth, you'd be better off getting a small switch or even a passive hub to put in place of the Netgear. Then you just set the internal LAN address on the pfSense to the same address as the one you were using on the Netgear, eliminating the need to have a separate external address on the Netgear. You can then set up port forwarding on the pfSense to send traffic to your internal server quite easily without having to double-port-forward through the Netgear as well.


  • Rebel Alliance Global Moderator

    Yeah why would you be setup wit a double nat like that?  If you want to use netgear as a switch..  Then just disable its dhcp server, and connect it to pfsense via one of its lan ports - then your other devices to the other lan ports of your netgear.

    You can still even use its wifi that way.  Doing it how you have drawn is a double nat - and other than pointless its also PITA..  All your devices should be on pfsense lan, and use pfsense as their gateway be it you want to keep in the 10.x.x.x you have or change pfsense lan to be your 192.168 network, etc.

    You then jut do your port forward on pfsense and your issues will go away.



  • Thanks. I'll give it a go. Told you….I'm new to networking and especially pfsense.