No longer receiving WAN IP



  • Since a week or 2 I can no longer receive an IP from my ISP with my pfsense box. It worked perfectly before. It all started when the router lost power and it had to power cycle. I tried changing the MAC-address to the router MAC that the ISP gave me but that didn't work either.
    I have reinstalled pfsense from scratch, with the same result.
    It keeps giving me 0.0.0.0 as IP. Everything in the local network works.
    I'm going to try connecting it again after work but I'd like some suggestions as to what could be wrong with it.
    Was there any update that could break DHCP lately? I'm was using the latest 2.2 (2.1.5 didn't support hardware), which I know is a beta but I have no other choice.

    UPDATE: Upon connecting the cable to other devices they receive an IP almost instantly.
    It's really pfsense doing something wrong.
    UPDATE2: It seems like a hardware/driver issue, which is weird because it was working before. It's a Gigabyte J1900-D3V with 2 realtek 8111E nics. It can't get a DHCP lease, doesn't matter what the source is. Not from my router and not from my ISP.
    Is there a ticket on this and if  no, where would I submit it?



  • you can see your ip if u go here http://www.whatismyip.com/ ?


  • Netgate

    Disconnect WAN, start a Diagnostics->Packet capture on WAN, connect WAN, let it run for about a minute, stop it and see what you see.



  • And just like that, upon wanting to try what you just said, I receive an IP.
    This is just weird
    I didn't change anything.
    If it somehow pops up again, I'll post the diagnostic log.