127.0.0.1 disappeared from pfSense DNS servers



  • So I've been up and running for the past day and a half or so, no connectivity issues or anything. So when I log in to my pfSense box tonight, I notice that the localhost IP address is no longer listed as a DNS server in the web interface. Sure enough, it's not listed in resolv.conf. I check the System > General Settings page and the box for Do not use the DNS Forwarder as a DNS server for the firewall is NOT checked, and it has never been.

    Just for grins, I tried cycling that option on then back off, but it still doesn't show the localhost address back in the DNS server list.

    DHCP is still handing out my LAN address as a DNS server though, and all name lookups are working without any problems. I am using Unbound (DNS Resolver), not dnsmasq (DNS Forwarder).



  • Are you sure it should be listed?

    I guess you are talking about the Dashboard? I am also using Unbound and there are only the following IPs listed:

    127.0.0.1
    nameserver1 to 4 of my ISP

    I also did NOT set the checkmark in the General Setup.

    You are expecting to see the 127.0.0.1?



  • Now thinking about it, you're correct… I should be referring to localhost (127.0.0.1) not my LAN address.



  • Just wanted to note that even after rebooting, 127.0.0.1 is still not listed among my pfSense box's DNS servers. It should be though.



  • I believe I fixed the last possible bug with Unbound not getting 127.0.0.1 set in resolv.conf yesterday. A couple days prior to that I added input validation to Services>DNS Resolver screen to not accept any config that won't bind to 127.0.0.1 if "Do not use" for localhost under General Setup is not checked.

    If you don't get 127.0.0.1 in resolv.conf on the most recent snapshot at the time of this post, go to Services>DNS Resolver and click Save. That'll kick back an error if your config isn't binding to localhost (and hence 127.0.0.1 also gets skipped from resolv.conf), which should be the only reason it's omitted.



  • After updating to the latest snapshot, it looks like it's back. Thanks!