Kernel for rt2860.ko missing



  • Hello everyone:

    Currently, I am running pfSense 2.2-BETA AMD64 on my firewall (Build 12/3/14 @ 11:33:23 CST) and when I try to run the command:

    
    kldload -v /boot/modules/rt2860.ko
    
    

    It gives me this error following the dmesg command:

    
    Error:
    kldload: an error occurred while loading the module. Please check dmesg(8) for more details.
    
    dmesg:
    KLD rt2860.ko: depends on kernel - not available or version mismatch
    linker_load_file: Unsupported file type
    
    

    It seems like it's missing the rt2860.kernel.ko file.  Is there anyway I can get this file by building the file in a FreeBSD in a Virtual PC and just SCP the file from the FreeBSD Virtual PC to the pfSense 2.2 box, or just wait until the next Beta release?

    Other than that, the OS is running smoothly, and the WebGUI Configuration page is crisp.



  • That's not a file we include, you're copying something over that isn't valid. What is it you're trying to accomplish? The ral driver that's included by default should work for that card.



  • Apparently, the wireless card isn't being detected at all.

    It's a PCI-E x1 Dual-Band 2.4/5GHz Wireless Card - ASUS PCE-N53 (Ralink RT2860 chipset)


Log in to reply