Lan connection fails to activate when connecting to pfsense server



  • Basically, have a 1 LAN, 2 WAN setup on a pfsesne machine. Up until now everything has been fine running directly connected to the LAN port from my laptop via a little switch. Just tried connecting a second laptop, and the lan card on that laptop wont activate…it's not obtaining an ip and still says disconnected. I know the card is working as have tested with something else. I know the cable and the switch are also working. Have tried plugging direct to the lan port on the pfsenese side...i thought bizarrely maybe it was a power issue, but no change.

    Very strange, never seen anything like this. I assumed if pfsense was blocking it, it would at least say connected, just obtain a wrong ip as it would be rejected by the dhcp, but it's not getting that far. Any suggestions appreciated!



  • With no switch between the pfSense and the client you need a crossover network cable (unless your client's nic does automdx, some newer ones do).



  • yeah i realised that just now, and this is def an older lan card, and i didn't use a cross over cable. however it still doesn't explain why it wont work through the switch, i tried the same port that the other laptop works fine through.



  • damn it, just tried my another machine and it works fine. seems like some incompatibility between an older card and the card or switch on the pfsense box.


Log in to reply