A1SRi-2758F (igb drivers) and MBUF in 2.2



  • As noted in this ticket: https://redmine.pfsense.org/issues/1221  "MBUFs are auto-scaled on FreeBSD 10.x so that much is done in a means that'll accommodate more hardware without changing from defaults there."  Referring to configuring /boot/loader.conf.local to values such as:

    kern.ipc.nmbclusters="131072"
    hw.igb.num_queues=2
    

    I had that configured while using 2.1 and it worked fine.

    I upgraded to 2.2-RC and removed that configuration, thinking it would not be needed based on the notes in the ticket.

    Upon first 2.2-RC boot, the box totally choked and used 100% of the MBUF (see attached).

    The only way I was able to get back into the box was to pull all interfaces, except the LAN, and wait for it to settle down.

    I then put the  /boot/loader.conf.local configuration back in and it is running fine now.

    So, the question is …. Why didn't the MBUF scale up?  Should they have?  It is known that the  /boot/loader.conf.local with custom setting is still required?

    Thanks




  • I have the same board and experience this problem too.

    Havent tried with RC release yet tho. Will test it asap.



  • Just installed 2.2 RC from Jan 11 2015. Still a problem here and I still need to fix this with this guide:

    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards



  • Brand new install on the same board. MBUF maxed out. Box non functional until increased nmbclusters in loader.conf.local. Did not limit the number of queues though and everything seems to be working fine



  • But will reducing the queue number affect performance? Is there any info on the optimal queue number for this board?


Log in to reply