Unbound fails silently?



  • I have two machines running 2.2 RC.  Both are identical hardware, with similar configurations.  No packages installed.  Since pursuing the 2.x tree, unbound has always worked on one, and never on the other.  On the inoperative one, it fails silently, with no log entries written.  Services shows unbound stopped, attempting to start it results in no errors, and it stays stopped.

    grep -r unbound * in /var/log shows 2 entries in user log where the user and groups are created for unbound, and that's it.

    unbound -v -d -c /var/unbound/unbound.conf results in:
    notice: Start of unbound 1.4.22.
    and it immediately stops.

    Is there somewhere else I should be looking?



  • If you increase the verbosity (-vvvv) what gets displayed?



  • [2.2-RC][root@.]/var/unbound: unbound -vvvv -d -c /var/unbound/unbound.conf
    [1418920283] unbound[10754:0] notice: Start of unbound 1.4.22.
    [1418920283] unbound[10754:0] info: ignored infra-lame-ttl: 900 (option removed, use infra-host-ttl)
    [1418920283] unbound[10754:0] debug: creating udp4 socket 192.168.xxx.yyy 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 192.168.xxx.yyy 53
    [1418920283] unbound[10754:0] debug: creating udp4 socket 192.168.aaa.bbb 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 192.168.aaa.bbb 53
    [1418920283] unbound[10754:0] debug: creating udp4 socket 127.0.0.1 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 127.0.0.1 53
    [1418920283] unbound[10754:0] debug: creating udp6 socket ::1 53
    [1418920283] unbound[10754:0] debug: creating tcp6 socket ::1 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 127.0.0.1 953
    [1418920283] unbound[10754:0] debug: switching log to syslog



  • @sazv:

    [2.2-RC][root@.]/var/unbound: unbound -vvvv -d -c /var/unbound/unbound.conf
    [1418920283] unbound[10754:0] notice: Start of unbound 1.4.22.
    [1418920283] unbound[10754:0] info: ignored infra-lame-ttl: 900 (option removed, use infra-host-ttl)
    [1418920283] unbound[10754:0] debug: creating udp4 socket 192.168.xxx.yyy 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 192.168.xxx.yyy 53
    [1418920283] unbound[10754:0] debug: creating udp4 socket 192.168.aaa.bbb 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 192.168.aaa.bbb 53
    [1418920283] unbound[10754:0] debug: creating udp4 socket 127.0.0.1 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 127.0.0.1 53
    [1418920283] unbound[10754:0] debug: creating udp6 socket ::1 53
    [1418920283] unbound[10754:0] debug: creating tcp6 socket ::1 53
    [1418920283] unbound[10754:0] debug: creating tcp4 socket 127.0.0.1 953
    [1418920283] unbound[10754:0] debug: switching log to syslog

    And it silently quits after that? Anything in /var/log/system.log ?



  • Quits silently, with no syslog entries at all.

    Strange, eh?



  • And by syslog, i meant /var/log/system.log.



  • @sazv:

    Quits silently, with no syslog entries at all.

    Strange, eh?

    yeah it is.

    @sazv:

    [2.2-RC][root@.]/var/unbound: unbound -vvvv -d -c /var/unbound/unbound.conf

    2 things
    First can you pm your unbound.conf and sanitise your private info and 2nd thing is I noticed your box does not seem to have a hostname set?



  • By the way after it logs 'switching to syslog..' it starts to log to /var/log/resolver.log. Does that have anything further?
    Also once you run that does a ps not show unbound running?



  • Nothing in syslog or resolver.log, and no unbound running.

    It was the hostname.  <facepalm>.  Strange that it didn't throw an error anywhere, though.</facepalm>


Log in to reply