[QUESTION] Custom Package Repo, again…



  • Hey guys,

    since 2.1 I'm using my own repo. I don't clone the "original", but add extra packages to the XML's and point to my own server. Till now everything went smooth, but I decided to go with 2.2.

    Snapshot: Wed Dec 17 10:56:19 CST 2014

    The webGUI shows me the "alert" that I have a custom repo configured. But installing my own packages, it tries to download from

    
    https://files.pfsense.org/packages/{$rel}/All/
    
    

    So I decided to edit "/etc/inc/pkg-utils.inc" at line 493 from

    
    $priv_url = "https://files.pfsense.org/packages/{$rel}/All/";
    
    

    to

    
    $priv_url = "https://my.own.server/packages/{$rel}/All/";
    
    

    Now it works, but it's hardcoded and changes in the webGUI won't have any effect.
    Had no time to look more in detail, but I would love to see this feature working again :)

    Thanks in advance



  • ~~It's getting weird… I installed my self created PBI and it was listed as "installed". Did a couple of reboots and it's gone from "installed" Packages, but it does work as it should.

    Available Packages:
    A list of all "default" available packages + my custom squid package

    Installed Packages after install, before reboot:
    mailreport
    my custom squid package

    Installed Packages after install, after reboot:
    mailreport
    no custom squid. it is listed under "available packages" again.

    BUT:
    After installation, custom squid is working as expected. No change to the functions after reboot. Everything runs smooth and squid is installed under "/usr/pbi/squid-amd64/".

    The PBI was created with the pfsense-tools. In 2.1.5 everything worked this way. Is it me or my pfense box? :o~~

    Seems that me is the problem…  ::)
    installed my custom squid again -> pfsense knows that it is a reinstall
    uninstalled it
    reboot
    installed
    reboot
    checked
    reboot
    checked
    reboot
    checked
    everything is fine :)

    will have a look on this on my other pfSense's. If there are similar issues, I will report back.

    The custom repo-URL is not solved. I need it hardcoded in my system.



  • Could someone please give me a hint where the download actually happens? I can't find the place where

    
    pkg_fetch_recursive
    
    

    is called. It looks like the base_url is not set properly…


Log in to reply