Bloqueio de imagem pelos squid.[RESOLVIDO]



  • e ai galera tudo tranquilo??

    vi aqui no fórum alguns tópicos relacionados a isso mas no achei a solução que preciso.

    configurei o squid + squidGuard pra bloquear sites com conteúdo sexual, ate ai blz ta bloqueando tudo certinho, porém se utilizar as pesquisa de imagem do google ele traz tudo liberado. Já marquei a opção de usar safe search no squidGuard mas continua liberando tudo tem algum jeito de bloquear essas imagens ?? ou forçar o usuario a usar o safe search??

    grato



  • voce utiliza proxy transpatente? acredito que dessa maneira o squidguard não conseguirá bloquear, tenta fazer com proxy ativo com wpad ou com interceptação ssl…

    proxy ativo não transparente com wpad... tudo automático não precisa configurar nos navegadores..

    http://www.pfsense-br.org/blog/2013/12/configuracao-wpad-no-pfsense-2-1/



  • sim estou utilizando o proxy transparente, vou testar o tutorial posto aqui o resultado.

    grato



  • Olá,
    O wpad é configurado no próprio pFsense e qual é a versão do squid?
    At.



  • Opa, sarge88

    Descreve mais o seu cenário ai (quais versões, como configurou, etc).

    Tenho um Pfsense aqui com Squid3 dev com filtro ssl + SquidGuard (Proxy transparente e autenticação via Captive Portal), que pra mim funciona perfeitamente o safe search.

    Qualquer duvida chama no skype (waldemar.p@hotmail.com)



  • opa e ai galera tudo tranquilo??

    estou usando o pfsense 2.1.5
    squid versao 2.7.9 pkg 4.3.4
    squidGuard versao 1.4.4 pkg 1.9.6

    não creio que seja problema de configuração a menos que precise de algo especifico para o google, pois fiz os testes no bing e funciona normalmente o safesearch, bloqueando e não deixando o usuário mudar, apenas no google que ta dando esse problema.
    tambem estou usando proxy transparente tudo funciona 100% exceto isto.



  • Squid 2 não intercepta ssl. O Google faz a pesquisa forçando ssl. acredito que não é o caso do bing.

    Tente achar um site bloqueado no squidguard,  em seguida tente acessar ele com https no lugar do http.

    Segundo teste,  configure um Proxy externo  https e/ou execute o ultra surf.

    Acredito que este teste possa te mostrar a necessidade de atualizar sua configuração de Proxy e versão do squid.



  • obrigado marcelloc

    optei utilizar o bing como buscador, enquanto configuro outra solução para o google deixando ele bloqueado por enquanto devido essa questão do ssl. irei verificar a versao do squid também pra ver a possibilidade de usar o squid 3

    obrigado


Log in to reply