Pfsense High CPU Usage (100%)



  • Hi Guys,

    I am new to pfSense, and lately my pfSense is whith  High CPU Usage (100%). The packages squid, lightsquid, openvpn, dhcp, dns, apinger is used. Below is the active system.

    
    last pid: 41540;  load averages:  2.22,  4.63,  4.15  up 0+00:22:33    17:49:55
    94 processes:  2 running, 78 sleeping, 14 waiting
    
    Mem: 94M Active, 34M Inact, 112M Wired, 88K Cache, 34M Buf, 3709M Free
    Swap: 4096M Total, 4096M Free
    
      PID USERNAME PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
       11 root     171 ki31     0K    16K RUN      0:46 52.98% [idle]
       12 root     -68    -     0K   224K WAIT     4:15 19.97% [intr{irq11: de0 de1 d}]
    38565 root      72    0   150M 45080K piperd   0:28 13.96% /usr/local/bin/php{php}
        3 root      -8    -     0K    16K -        0:25  0.98% [g_up]
        0 root     -16    0     0K   128K sched    2:52  0.00% [kernel{swapper}]
    29694 root      44    0 26280K  5852K kqread   0:56  0.00% /usr/local/sbin/lighttpd -f /var/etc/lighty-we
       12 root     -32    -     0K   224K WAIT     0:40  0.00% [intr{swi4: clock}]
        4 root      -8    -     0K    16K -        0:40  0.00% [g_down]
      258 root      76   20  6908K  1384K kqread   0:33  0.00% /usr/local/sbin/check_reload_status
       12 root     -64    -     0K   224K WAIT     0:23  0.00% [intr{irq14: ata0}]
    38038 root      76    0   150M 46072K accept   0:14  0.00% /usr/local/bin/php
    21065 root      44    0  5784K  1488K select   0:06  0.00% /usr/local/sbin/apinger -c /var/etc/apinger.co
    83942 root      64   20 13496K  4492K select   0:04  0.00% /usr/local/sbin/openvpn --config /var/etc/open
    76113 proxy     64   20 48648K 19060K kqread   0:04  0.00% (squid-1) -f /usr/pbi/squid-amd64/etc/squid/sq
       12 root     -44    -     0K   224K WAIT     0:02  0.00% [intr{swi1: netisr 0}]
    46120 root      76   20  8296K  1812K wait     0:01  0.00% /bin/sh /var/db/rrd/updaterrd.sh
       14 root     -16    -     0K    16K -        0:01  0.00% [yarrow]
    30309 root      76    0   144M 22904K wait     0:01  0.00% /usr/local/bin/php
    
    

    Obs.: The cache of squid already been deleted.

    Someone help me?

    Thank you



  • you running under hyper-v ?
    have you tried the 2.2 snapshots ? (they'r supposed to have much much better support for hyper-v)



  • yes , i'm running in hyper-v .

    2.2 snapshot would be the version? can explain me better?



  • 2.2 is the version that is currently being developed. (not finished, still contains bugs )  = based on freebsd10.1 ==> should have much better performance under hyper-v (using paravirtualized network cards out of the box)
    https://blog.pfsense.org/?p=1506

    all the 2.1.X series are based on freebsd 8.3 == horrible performance under hyper-v



  • my version is 2.1.5 . how do i upgrade to the 2.2 version, without having to uninstall?



  • change update URL in system–>firmware-->updater settings
    also be sure to check "unsigned images"

    @jimp:

    That one still works for me, though you can use the "real" one instead:

    http://snapshots.pfsense.org/FreeBSD_releng/10.1/i386/pfSense_RELENG_2_2/.updaters/
    or
    http://snapshots.pfsense.org/FreeBSD_releng/10.1/amd64/pfSense_RELENG_2_2/.updaters/

    The 2.2 line was officially branched so it is no longer "HEAD"

    pick the correct one for your system (either 64bit=amd64 or 32bit=i386)



  • I upgraded to version 2.2, but the CPU usage remains at 100%. There anything else I can do?



  • did you change your virtual network adaptors to the para-virtualized ones ?


Log in to reply