Dynamic DNS broken in Pfsense 2.1.5



  • Getting the following errors when attempting to setup dynamic DNS (I use DNS Exit)

    Dec 23 02:02:07 php: /services_dyndns_edit.php: DynDns: updatedns() starting
    Dec 23 02:02:07 php: /services_dyndns_edit.php: DynDns (mydomainname.com): x.x.x.x extracted from local system.
    Dec 23 02:02:07 php: /services_dyndns_edit.php: DynDNS (mydomainname.com): running get_failover_interface for wan. found em0
    Dec 23 02:02:07 php: /services_dyndns_edit.php: DynDNS (mydomainname.com): DynDns _update() starting.
    Dec 23 02:02:07 php: /services_dyndns_edit.php: DynDNS (mydomainname.com): DynDns _checkStatus() starting.
    Dec 23 02:02:07 php: /services_dyndns_edit.php: DynDNS (mydomainname.com): Current Service: dnsexit
    Dec 23 02:02:07 php: /services_dyndns_edit.php: Curl error occurred: SSL certificate problem: unable to get local issuer certificate

    Thanks



  • 2.1x doesn't have ca_root_nss and when dnsexit was changed to use HTTPS there wasn't an option added to disable cert verification. In 2.2, that all just works. For 2.1.5, you can edit /etc/inc/dyndns.class and below this line:

    case 'dnsexit':
    

    add a new line with the following:

    curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, FALSE);
    

    when you upgrade to 2.2 that'll be overwritten and it'll work normally with proper cert verification.



  • Thanks!


Log in to reply