Loading available packages failure



  • Hi,

    I'm new to pfSense and got it up and running.

    For internet access I configured it to use a proxy server. In the dashboard the version check works fine.
    But when I opened the package manager and tried to get the available packages it couldn't fetch the list of available packages.

    From the logs of my proxy I figured pfSense tried to load the list from https://packages.pfsense.org, which failed with a 501.

    After configuring the package manger (https://pfsense/pkg_mgr_settings.php) to use http://packages.pfsense.org as repository it worked.

    Resetting the config to standard I'll get "Unable to retrieve package info from https://packages.pfsense.org. Cached data will be used."

    So the only difference is the SSL access. Why does it work with HTTP, but not with HTTPS?

    Tom

    P.S.: It's 2.1.5



  • maby your proxy is blocking some https traffic?

    check logs on this side as you try to download packages and try to spot some rejected requests from the proxy.

    Zikmen


Log in to reply