Unbound package 1.5.1_2 issue



  • Dear All,

    I am running four servers with 2.1.5-RELEASE (amd64) on Intel(R) Atom(TM) CPU C2758 @ 2.40GHz. Two servers are at each end of a VPN connection using carp.

    Unbound is in use for a long time on all servers without issues. When upgrading the unbound package to 1.5.1_2 today, the pair of servers on one side keeps in good shape while the pair of servers on the other side fail in a way that I had to revert to the DNS forwarder.

    All my efforts to determine reasons for the difference in behavior did fail. I tried to align packages used, disabled shell commands run and the like. The pair of servers at one end does fail. Resources are not limited in general, e. g., 19 % of the 16GB of RAM are in use. The failing side has more VLAN interfaces and has 1:1 NAT in use, however, that should not be critical, I think.

    The system log then contains the following message:

    php: config.inc: The command '/usr/pbi/unbound-amd64/sbin/unbound-control start' returned exit code '1', the output was '[1419330513] unbound[44948:0] warning: too many file descriptors requested. The builtinmini-event cannot handle more than 1024. Config for less fds or compile with libevent [1419330513] unbound[44948:0] fatal error: too much tcp. not enough fds.'

    To me, this looks like the following issue:

    https://redmine.pfsense.org/issues/4020

    Is there a way to re-enable unbound on the affected systems?

    Regards,

    Michael Schefczyk


  • Administrator

    PBI was built without LIBEVENT because option name has changed. I'm building fresh PBIs and will let you know as soon as they are ready


  • Administrator

    Done, please update to 1.5.1_2_1, make sure PBI is reinstalled since its version didn't change.



  • Thank you very much for your prompt response, Renato! Deleting unbound 1.5.1_2 and installing 1.5.1_2_1 makes unbound work again on all four servers. Regards, Michael


Log in to reply