• 2.2-RC (i386)
    built on Tue Dec 23 05:11:17 CST 2014

    Whenever I try to create a new ipv6 gateway, I get the message:
    "The gateway address 2001:xxxx:xxxx:xxxx::1 does not lie within one of the chosen interface's subnets."
    The IPv6 interface ip address is 2001:xxxx:xxxx:xxxx::2/64.

    Also, after upgrading to RC2.2, a new gateway were created that I cannot delete:
    "Interface WAN6_TUNNELV4 Gateway"

    In addition, I am not able to add any useful information to the new "Interface WAN6_TUNNELV4 Gateway", so this release effectively leaves me without IPv6 connectivity.

    I also tried to rename the "Interface WAN6_TUNNELV4 Gateway", but received an error message "Changing name on a gateway is not allowed." Not sure why, as the GW is not in use.

    When trying to assign the "Interface WAN6_TUNNELV4 Gateway" to the WAN6 interface, it is not available in the dropdown.

  • what type of interface is it?

  • GIF

  • You don't manually add gateways for gif interfaces, the interface's _TUNNELV6 auto-added gateway is all you need.

  • Hmm, ok.
    There are no ip addresses anywhere in the gateway config. Also, I cannot assign the gateway to the interface.

    Please see attachment for the gateway config. I have tried to change the address family from IPv4 to IPv6, but it seems I cannot change anything on this gw.

    In addition, in the "gateways" dashboard, the gw is listed with "Unknown" status.

    But most importantly, I cannot route any traffic through the GIF interface anymore. I can ping the remote IPv6 end of GIF from the local end, but not route traffic.

  • There wouldn't be a v4 IP on there, so the v4 gateway looking that way is normal. You should also see the v6 gateway there, as a separate entry from that, as WAN6_TUNNELV6. You definitely don't want that TUNNELv4 gateway marked as default, set your Internet connection's v4 gateway as the default.

  • Unfortunately, there is no autogenerated gw for IPv6, and I am not able to create one myself.

  • How is Interfaces>WAN6 configured on your system? Should be "none" for both IPv4 and IPv6.

  • Close to perfect!

    When setting WAN6 both IPv4 and IPv6 to "None", GW for both IPv4 and IPv6 were created. After setting IPv6 GW to default, IPv6 traffic is back to normal. Awesome.

    The issue occured as I had IP configuration for WAN6, which I think is mandatory for GIF in 2.1.5. I also had a manually configured GW for IPv6 from 2.1.5 which I manually deleted.

    I disabled the auto generated GW for GIF IPv4, as it is not in use, but it is still visible in the "Dashboard -> Gateways". Is it possible to have disabled gateways hidden from the dashboard?


  • It wasn't mandatory in 2.1x, but in some circumstances it was possible to configure either way and it'd work. It shouldn't have been configured that way, our documentation has always shown "none"/"none" there.

    The v4 gateway will just be there for now. We'll clean that up some point post-2.2 so it only shows gateways for protocols that are enabled on that interface. It won't hurt anything in the mean time.