Jmicron support from 1.2-RC1 missing in 1.2 Final?



  • I wanted to upgrade my firewall cluster from 1.2-RC1 to 1.2 Final.
    So i took one server offline and tried to do a clean install.
    Booted up the pfsense 1.2 Final from CDrom and went to do install (99).
    But installer informed me that it can't find any disks.

    Just to be sure i inserted 1.2-RC1 CD and it does find the disk on jmicron controler.

    I have another SATA controller on-board, but on one machine (from two identical) it won't load the kernel even if I put in the disk which works on the other one and plug it to any sata port. I went around this problem by putting disk on jmicron, but since it doesn't work anymore it's back to 1.2-RC1 for me. :-(

    Should i submit bug report? Any other info?



  • We haven't removed any drivers between RC1 and final.

    Can you post a full dmesg from the box when it's working? should be able to find it on status.php.



  • Here is my full dmesg.
    But right now i'm on 1.2 final since pfsense booted O.K. when I configured in BIOS other - non jmicron - controller in RAID mode. :-) Makes no sense, but it works. If i disable raid i get "can't load kernel" no matter to what non jmicron SATA port i plug the disk to. I have disabled jmicron controler in bios since there is no need for it now. If you really wish, I could go to firewalls attach one monitor and enable jmicron again and post you dmesg with enabled jmicron.

    Copyright © 1992-2007 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 6.2-RELEASE-p11 #0: Sun Feb 24 16:49:14 EST 2008
        sullrich@builder6.pfsense.com:/usr/obj.pfSense/usr/src/sys/pfSense_SMP.6
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz (1862.01-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x6f6  Stepping = 6
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0xe3bd<sse3,rsvd2,mon,ds_cpl,vmx,est,tm2,<b9>,CX16,<b14>,<b15>>
      AMD Features=0x20100000 <nx,lm>AMD Features2=0x1 <lahf>Cores per package: 2
    real memory  = 2146304000 (2046 MB)
    avail memory = 2090950656 (1994 MB)
    ACPI APIC Table: <award  awrdacpi="">FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP): APIC ID:  1
    ioapic0: Changing APIC ID to 4
    ioapic0 <version 0.3="">irqs 0-23 on motherboard
    ioapic1 <version 0.3="">irqs 24-47 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    acpi0: <award awrdacpi="">on motherboard
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi0: Power Button (fixed)
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    cpu0: <acpi cpu="">on acpi0
    acpi_perf0: <acpi cpu="" frequency="" control="">on cpu0
    cpu1: <acpi cpu="">on acpi0
    acpi_button0: <power button="">on acpi0
    acpi_button1: <sleep button="">on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    pci0: <base peripheral,="" interrupt="" controller=""> at device 0.5 (no driver attached)
    pcib1: <pci-pci bridge="">at device 1.0 on pci0
    pci1: <pci bus="">on pcib1
    pcib2: <acpi pci-pci="" bridge="">irq 27 at device 2.0 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    pci2: <display, vga="">at device 0.0 (no driver attached)
    pci2: <display>at device 0.1 (no driver attached)
    pcib3: <acpi pci-pci="" bridge="">irq 31 at device 3.0 on pci0
    pci3: <acpi pci="" bus="">on pcib3
    atapci0: <via 8237a="" sata150="" controller="">port 0xfc00-0xfc07,0xf800-0xf803,0xf400-0xf407,0xf000-0xf003,0xec00-0xec0f,0xe800-0xe8ff irq 21 at device 15.0 on pci0
    ata2: <ata 0="" channel="">on atapci0
    ata3: <ata 1="" channel="">on atapci0
    atapci1: <via 8237a="" udma133="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xe400-0xe40f at device 15.1 on pci0
    ata0: <ata 0="" channel="">on atapci1
    ata1: <ata 1="" channel="">on atapci1
    uhci0: <via 83c572="" usb="" controller="">port 0xe000-0xe01f irq 20 at device 16.0 on pci0
    uhci0: [GIANT-LOCKED]
    usb0: <via 83c572="" usb="" controller="">on uhci0
    usb0: USB revision 1.0
    uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <via 83c572="" usb="" controller="">port 0xdc00-0xdc1f irq 22 at device 16.1 on pci0
    uhci1: [GIANT-LOCKED]
    usb1: <via 83c572="" usb="" controller="">on uhci1
    usb1: USB revision 1.0
    uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub1: 2 ports with 2 removable, self powered
    uhci2: <via 83c572="" usb="" controller="">port 0xd800-0xd81f irq 21 at device 16.2 on pci0
    uhci2: [GIANT-LOCKED]
    usb2: <via 83c572="" usb="" controller="">on uhci2
    usb2: USB revision 1.0
    uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub2: 2 ports with 2 removable, self powered
    uhci3: <via 83c572="" usb="" controller="">port 0xd400-0xd41f irq 23 at device 16.3 on pci0
    uhci3: [GIANT-LOCKED]
    usb3: <via 83c572="" usb="" controller="">on uhci3
    usb3: USB revision 1.0
    uhub3: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub3: 2 ports with 2 removable, self powered
    ehci0: <via vt6202="" usb="" 2.0="" controller="">mem 0xdffff000-0xdffff0ff irq 21 at device 16.4 on pci0
    ehci0: [GIANT-LOCKED]
    usb4: EHCI version 1.0
    usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
    usb4: <via vt6202="" usb="" 2.0="" controller="">on ehci0
    usb4: USB revision 2.0
    uhub4: VIA EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
    uhub4: 8 ports with 8 removable, self powered
    isab0: <pci-isa bridge="">at device 17.0 on pci0
    isa0: <isa bus="">on isab0
    pcib4: <acpi pci-pci="" bridge="">at device 19.0 on pci0
    pci4: <acpi pci="" bus="">on pcib4
    pcib5: <acpi pci-pci="" bridge="">at device 19.1 on pci0
    pci5: <acpi pci="" bus="">on pcib5
    em0: <intel(r) 1000="" pro="" network="" connection="" version="" -="" 6.2.9="">port 0x9c00-0x9c3f mem 0xdfbe0000-0xdfbfffff,0xdfcc0000-0xdfcdffff irq 17 at device 3.0 on pci5
    em0: Ethernet address: 00:0e:0c:d8:09:60
    em1: <intel(r) 1000="" pro="" network="" connection="" version="" -="" 6.2.9="">port 0x9800-0x983f mem 0xdfca0000-0xdfcbffff,0xdfc80000-0xdfc9ffff irq 18 at device 4.0 on pci5
    em1: Ethernet address: 00:0e:0c:d0:ae:93
    em2: <intel(r) 1000="" pro="" network="" connection="" version="" -="" 6.2.9="">port 0x9400-0x943f mem 0xdfc60000-0xdfc7ffff,0xdfc40000-0xdfc5ffff irq 19 at device 5.0 on pci5
    em2: Ethernet address: 00:0e:0c:d0:db:90
    em3: <intel(r) 1000="" pro="" network="" connection="" version="" -="" 6.2.9="">port 0x9000-0x903f mem 0xdfc20000-0xdfc3ffff,0xdfc00000-0xdfc1ffff irq 16 at device 6.0 on pci5
    em3: Ethernet address: 00:0e:0c:d0:e0:10
    re0: <realtek 8169sc="" 8110sc="" single-chip="" gigabit="" ethernet="">port 0x8c00-0x8cff mem 0xdfcff000-0xdfcff0ff irq 20 at device 7.0 on pci5
    miibus0: <mii bus="">on re0
    rgephy0: <rtl8169s 8110s="" media="" interface="">on miibus0
    rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX, 1000baseTX-FDX, auto
    re0: Ethernet address: 00:17:31:5f:2f:e0
    re0: [FAST]
    acpi_tz0: <thermal zone="">on acpi0
    speaker0: <pc speaker="">port 0x61 on acpi0
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A
    ppc0: <ecp parallel="" printer="" port="">port 0x378-0x37f,0x778-0x77b irq 7 drq 3 on acpi0
    ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
    ppc0: FIFO with 16/16/16 bytes threshold
    ppbus0: <parallel port="" bus="">on ppc0
    lpt0: <printer>on ppbus0
    lpt0: Interrupt-driven port
    ppi0: <parallel i="" o="">on ppbus0
    pmtimer0 on isa0
    orm0: <isa option="" roms="">at iomem 0xc0000-0xcefff,0xd5000-0xd5fff,0xd6000-0xd6fff,0xd7000-0xd7fff,0xd8000-0xd8fff on isa0
    atkbdc0: <keyboard controller="" (i8042)="">at port 0x60,0x64 on isa0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounters tick every 1.000 msec
    Fast IPsec: Initialized Security Association Processing.
    ad4: 305244MB <seagate st3320620as="" 3.aak="">at ata2-master SATA150
    SMP: AP CPU #1 Launched!
    Trying to mount root from ufs:/dev/ad4s1a

    ___
    ___/ f \
    / p \___/ Sense
    \___/  \
        \___/

    Welcome to pfSense 1.2-RELEASE on the 'pfSense' platform…

    Mounting filesystems...
    done.
    Creating symlinks...
    .
    .
    .
    done.
    Launching PHP init system...
    done.
    Initializing...
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    done.
    Starting device manager (devd)...
    done.
    Loading configuration...
    .
    .
    .
    done.
    Updating configuration...
    done.
    Cleaning backup cache...
    done.
    Setting up extended sysctls...
    done.
    Syncing user passwords...
    done.
    Starting Secure Shell Services...
    done.
    Setting timezone...
    done.
    Starting syslog...
    done.
    Configuring LAN interface...
    re0: link state changed to UP
    re0: link state changed to DOWN
    done.
    Configuring WAN interface...
    em0: link state changed to DOWN
    done.
    Configuring OPT interfaces...
    done.
    Configuring CARP interfaces...
    em0: promiscuous mode enabled
    done.
    Syncing system time before startup...
    re0: link state changed to UP
    em0: link state changed to UP
    done.
    pflog0: promiscuous mode enabled
    Configuring firewall...
    .
    .
    .
    done.
    Starting webConfigurator...
    done.
    Starting DNS forwarder...
    done.
    Setting up microcode and tx/rx offloading...
    done.
    Starting FTP helpers...
    done.
    Waiting for final CARP interface bringup...
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    done.
    done.
    Generating RRD graphs...
    done.
    Starting OpenNTP time client...
    done.
    Starting CRON...
    done.
    Executing rc.d items...
    Starting /usr/local/etc/rc.d/*.sh...
    done.
    appending output to nohup.out
    Bootup complete
    arp_rtrequest: bad gateway 85.10.35.2 (!AF_LINK)</seagate></generic></system></at></keyboard></isa></parallel></printer></parallel></ecp></pc></thermal></rtl8169s></mii></realtek></intel(r)></intel(r)></intel(r)></intel(r)></acpi></acpi></acpi></acpi></isa></pci-isa></via></via></via></via></via></via></via></via></via></via></ata></ata></via></ata></ata></via></acpi></acpi></display></display,></acpi></acpi></pci></pci-pci></acpi></acpi></sleep></power></acpi></acpi></acpi></award></version></version></award ></lahf></nx,lm></b15></b14></sse3,rsvd2,mon,ds_cpl,vmx,est,tm2,<b9></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>



  • This is likely related to the fact that we switched from a default SMP kernel to uniprocessor on the live CD. You can install from 1.2-RC2 and earlier, then upgrade via the web GUI or console upgrade to 1.2 release.

    1.2.1 will switch back to the SMP kernel on the live CD because of strange issues with hardware not working that should with the uniprocessor kernel. This appears to be another instance of this.


Log in to reply