Long Term Solution for bind and "journal rollforward failed" ?



  • Hi all,

    I am using the current bind package with pfSense 2.1.5.

    From time to time I am getting the well-known error about "journal rollforward failed: not exact".

    As usual, stop bind, rm all .jnl files under /cf/named/etc/named.conf and start bind again. Fixed.

    But I have to do this every time it happens by hand. Until done the named is then stopped regarding this zone.
    How can I prevent this error in advance?

    I have disabled the "Enable registration of DHCP client names in DNS." so why does bind create journal files? It is the master and I am editing the zone only through the WebGUI.

    How can I prevent bind from creating .jnl files as I do not want to have some dynamic hosts added.

    Any ideas?

    Christian


Log in to reply