Suricata install failed: 2.2 or package issue or both?



  • This is what I get trying to install the suricata package:

    Installation of suricata FAILED!
    
    Beginning package installation for suricata .Saving updated package information... done.
    Downloading suricata and its dependencies... 
    Checking for package installation... 
     Downloading https://files.pfsense.org/packages/10/All/suricata-2.0.4-amd64.pbi ...  (extracting)
    Loading package configuration... failed!
    
    Installation aborted.Removing package...
    Starting package deletion for suricata-2.0.4-amd64...done.
    Removing suricata components...
    Configuration... done.
    done.
    Failed to install package.
    
    Installation halted.
    


  • Strange, just for kicks, I tried a second time to run the install: now it worked.
    I leave these posts, just in case this points towards some issue with the installer, otherwise, I'd just nuke my previous post.



  • https://github.com/pfsense/pfsense-packages/commit/28c552b11ab71035755720ff2a6092f45b961439
    There was a bug-fix update to Suricata just some hours ago. That fixed an installation issue for first-time installs of Suricata. Maybe you got the previous version, then next the new version that works.


Log in to reply