Diagnostics: DHCP Leases



  • I assign static IP's to all users on the network and i'm adding and removing them on a fairly regular basis. Once i've Applied the changes to the DHCP the DHCP Leases (Status->DHCP Leases) shows everyone as being online rather then before where it shows who is online and who is off line. I have tried restarting the DHCP service but has no effect the only way I can get it to work is by reseting the Firewall.

    Is there anything that i've missed??

    This is a silly bug just pointing it out so don't stress!!

    Thanks Tim

    P.S pfsense is working amazingly for me thanks alot to the whole team.



  • How do you assign static IPs?
    Do you set them on the client or do you assign static DHCP leases from the DKCP leases tab?

    Anyway, once a DHCP lease is assigned to a MAC address, pfSense saves the info and does not forget about it.
    Here's the info on why and how to get rid of them again:  http://forum.pfsense.org/index.php/topic,5231.msg41202.html#msg41202

    AFAIK, down the road SUllrich wants to delete the entries when assigning a static lease. For now you've got to do it manually.



  • I assign them from the DHCP leases tab.

    Its not gettin rid of them that is the problem. Its that once i modify one of them i can no logner see who is online or not because they all say online.



  • Did you clean /var/dhcpd/var/db/dhcpd.leases~  and /var/dhcpd/var/db/dhcpd.leases  as suggested in the linked thread?
    The problem should go away then.


Locked