Help Anyone :-(



  • Hello all,
                Ive successfully installed pfsense and got it working :-) However I cant access my synology server for some reason.Any help would be greatly appreciated.My switch is on OPT1 but I can't access whats on it through the pc.

    Thanks Gary



  • If the client PC is on OPT1 and the Synology is on LAN, then you need to have pass rule/s on OPT1 to allow that traffic (and whatever other traffic you wish to allow that comes from OPT1 devices).
    Post some detail of the interfaces, subnets and rules that you have.



  • I have the pc on LAN and switch on OPT1.Shall i restart the whole process? Thanks



  • The default allow all rule on the LAN interface should be letting the client PC on LAN connect to the file server on OPT1.
    With the PC and file server on different subnets you will not be able to just browse for it. You will need to use the server IP address, or add a host override in the pfSense DNS to give a name for the file server that translates to its IP address in OPT1.
    The file server will have to have an IP address in OPT1 subnet, and have its gateway set to the pfSense OPT1 address so that it can reply.



  • Thanks, still totally lost with this networking.I have 3 ports on the pfsense.1 goes to the pc known as (LAN), 1 goes to the modem (WAN) and one goes to the switch(OPT1).On the switch is where the server is.Im not really network savvy, so sorry about this.I have got a Asus A66u but i want to use that as a access point in my living room.Thanks



  • Is there a reason that you want the PC on a different interface/subnet to the other equipment on the OPT1 switch?

    What are the IP addresses/netmasks on LAN and OPT1 interfaces?

    What are the IP addresses of the LAN PC and of OPT1 file server?



  • IP address of LAN is 192.168.1.1
    IP address of OPT 1 is just DHCP

    I've find given it an IP but it keeps connecting to Pfsense and not the switch.

    Currently connected to the switch are my 3 bedrooms,Synology server and my HTPC in the living room.

    Thanks for this Phil



  • To use OPT1 as an internal interface you need to give it an IP address/netmask. An interface that asks for DHCP (a DHCP client) is for an uplink to the internet.

    In a simple home situation you would connect the switch to LAN, and all devices to the switch. Everything gets an IP in 192.168.1.* from the pfSense DHCP server.

    If you have some reason to also have OPT1, then give it a different IP address/subnet - like 192.168.2.1/24. Enable DHCP on OPT1 with some pool of addresses like 192.168.2.100-192.168.2.200, switch off DHCP on any other network device (like an access point) - you want DHCP to only come from pfSense. Put a rule on OPT1 to pass all. That will make it work.

    Once all is working you can start thinking about what restrictions you want, and how to make the firewall rules more restrictive to do it.



  • Thankyou so much Phil i'll give that a go

    My home isn't that simple.I have the co-ax leading into the modem in the conservatory which is where my pc is.Then I have a network point which leads to the switch

    I'll let you know how it goes :-)

    Thanks again



  • No luck with that Phil. No matter what I do it just wont pick up


  • Banned

    Where are you located in real life??



  • UK


  • Banned

    Want to do a teamviewer session?



  • Yes, PM sent



  • Damn!! he's offline. Any help with teamviewer?


  • Banned

    Replied to the email :)


  • Banned

    Problem solved. Misconfigurated PFsense interfaces was the culprit.

    OP donated 20£ as a thankyou for solving the issue and they are much appreciated.


Log in to reply