Dual Band Wifi AP with pfSense 2.2



  • Hi All,

    I have an Atheros 9220 mini-pci card sitting in my soekris net5501 and would like to configure both the 2.4GHz and 5GHz bands in pfsense. I tried doing this by creating "virtual" interfaces in Interfaces->Assign->Wireless. I then tried to setup 2 WLAN interfaces and selected 2.4GHz and 5GHz modes respectively when configuring the interfaces. What I have noticed is that both the interfaces operate at either 2.4GHz or 5Ghz but not both simultaneously. Is this a supported configuration in pfSense?

    I have seen people mentioning that they have got it to work, but I cannot, for the life of me, find any tutorial on how to do it, or if there are any specific settings I need to apply to get it working.

    Any comments/suggestions/links on how to get it working would be greatly appreciated.

    This is the output of my dmesg relating to the atheros interface:

    
    ath0: <atheros 9220="">mem 0xa0010000-0xa001ffff irq 15 at device 17.0 on pci0
    [ath] enabling AN_TOP2_FIXUP
    ath0: [HT] enabling HT modes
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9220 mac 128.2 RF5133 phy 13.0
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0</atheros> 
    

    I cannot recall the exact vendor/model of the device, but I think this link is the closest I've found to describe my card.



  • It's working as expected. One radio can operate at either 2.4 or 5ghz - not both simultaneously. If you want concurrent dual band then you need a second card/radio installed.



  • @thermo:

    It's working as expected. One radio can operate at either 2.4 or 5ghz - not both simultaneously. If you want concurrent dual band then you need a second card/radio installed.

    Hi, Thanks for the info, however, I was under the impression this particular card had 2 radio's, I'll have to confirm that, maybe the dmesg output is a little misleading then, specifically:

    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0


Log in to reply