[SOLVED]haproxy-devel bug after upgrade to pkg v 0.14



  • after updating the haproxy-devel pkg v 0.14 on the acl rules are not properly loaded / saved.

    I also once again deleted everything and refurbished but without success.

    There are set rules partly also the acl that are not configured in the GUI. If these cached somewhere?

    Saving the control works fine. No errors.

    I have a primary frontend which is on the WAN side http and https open.

    More frontends with other ACL's are linked to the primary Shared frontend.

    If I use only the main frontend, then do the acl rules.

    After adding shared frontends do not work the rules.

    With the pkg v 0.13 the rules have all worked.



  • Hi tommytiger,

    Sorry, i seem to have introduced a bug there. Should get fixed by v0.15 for which i send a pullrequest https://github.com/pfsense/pfsense-packages/pull/764.

    You could probably pull it with 'system patches' package, just make sure to set the correct base dir /usr/local/pkg/ , and strip option (i think it will need to be 4).
    It will probably get committed to main pfSense repository in a day..

    Greets PiBa-NL



  • Many many thanks for the quick response. It works again everything was perfect. Thx


Log in to reply