UVerse TV behind pfsense



  • I have been working on this all day and cant figure it out.  I switched over from Untangle firewall as I kept having grub errors and having to reinstall so i figured i would try pfsense.  The way my network is setup is as follows

    ISP(modem/router UVerse)–---pfsense-----Cisco 2960

    I have pfsense handing out dhcp leases to vlans 10,20,40 and have my uverse tv boxes plugged into the switchports on the cisco 2960.

    On untangle i had it setup as a transparent firewall and my uverse tvs members of vlan 1 which was the dhcp leasing of the uverse modem/router.  This allowed me to plug the tvs into the 2960 switch and it worked great.  I can not seem to get it to work in pfsense though.  Ive tried setting up the transparent mode but cant get it to work and dont know if this is the right way to go about doing it.  Any help is greatly appreciated.

    Marcus



  • Hi,

    there isn't enough information posted, is the uverse device configured for outbound NAT or is the WAN of that device being bridged to the PFsense WAN interface?  this is how you should be doing this given that the handoff will make for easier troubleshooting of issues regarding NAT and routing in general, are the VLANs in question being trunked properly to the Cisco Switch?  can you ping the SVI on the PFSense vlan interface?  if so can you ping your WAN interface? if not verify your firewall rules to allow a rule out to the internet from that particular SVI on the pfsense firewall… can the firewall itself ping your TV ip addresses?  do your TV's receive an IP address?

    There are just a lot of details about this problem that are unknowns.

    switch port to trunk pfsense should be something like:

    switchport port trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlans (#)
    spanning-tree portfast trunk

    verify speed and duplex settings etc..

    these are some steps your can try, but by no means all of them.


Log in to reply