LiveCD to USB install: ROOT MOUNT ERROR



  • Greetings all!

    I'm a complete gnuub to pfSense, so i could use a hand on setting on my first build.

    I am running pfSense off USB for the time being  I need my HDD in it, and when i get back to my other house after the break, I will be installing my SSD to the box, and making it a permanent install on the SSD (pfSense blows my old DD-WRT routers away).

    Anywho…here's the box:
    -  Dual core 2.8 ghz, 4gig ram, usb controllers are mobo controllers. 
    -  1 mobo NIC (nvidia nforce _)
    -  1 pci-x Dual Lan Intel Server NIC

    Zee problem:
    -  I load LiveCd (burnt to CD), and setup WAN, LAN, and can access through browser.  HOWEVER,
    -  Once i do a 99-> Install, i choose custom and put it on my 8gb flash drive.  The 8 gig flash will boot partially (i.e., it shows the boot menu, etc), but i get a "Trying to mount root from ufs:" error "ROOT MOUNT ERROR".  I've spent countless hours trying to find workarounds, etc, but with no avail.  Please advise.

    ~\  uPDATE  /~  I fingered it out…. at the moment, i have to do following:

    mountpoint> ufs:/dev/da2s1a

    how i can i add this to the boot loader?  i know a little Linux CLI, but have very little FreeBSD CLI under zee belt. _


  • Netgate Administrator

    It's an 8GB USB drive you're booting from yes?

    Try selecting option 3, boot from USB, at the initial boot menu. That introduces a delay so that the usb device can initialise before the kernel tries to mount it. If that works then you can make that change permanently by adding:

    kern.cam.boot_delay="10000"
    

    to the file /boot/loader.conf.local
    That file will have to be created. See:
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#Booting_from_USB

    You can do it in one easy step by executing the following line at the Diagnostics: Command Prompt: Command: box

    echo 'kern.cam.boot_delay="10000"' >> /boot/loader.conf.local
    

    Steve


Log in to reply