WAN IP–-DHCP and STATIC Issues



  • I have installed Pfense 2.1.5 in Virtual Box. The installation of both Pfsense and VirtualBox are not problematic. In fact, after configuring Pfsnese to obtain an DHCP IP address off my network router andsetting up the local LAN in Pfsense everything works fine. It's when I set up the Pfsense WAN as a STATIC IP address that I lose Internet connectivity on my Windows Server 2008. For example, setting up the WAN for DHCP, I get a 192.168.9.90 address and for the LAN, I setup something like 192.168.8.1 and at that stage everything works. So if I go in to reconfigure the WAN, to keep that same IP address (192.168.0.90) as a STATIC IP, then my Internet connection is lost to the W2K8 server…My server network settings are: 192.168.8.2, 255/24, 192.168.8.1 (DG), DNS 192.,168.8.1 and 4.2.2.2. What am I doing wrong when trying to set the WAN up to be static.



  • When you setup static WAN you have to add an upstream gateway for that and give it the IP address of that upstream router.
    Other than that, it should "just work".



  • I agree on having to setup the "upstream gateway" which in my case would be 192.168.0.1…But when i configure the WAN setting, all I get is the set WAN IP and subnet mask...



  • You need to add the gateway in IPv4 Upstream Gateway row, by clicking "add a new one".




  • Phil, Thanks for the assistance. As I recall setting Pfsense up on another VM, I was given the option at the command line so to speak, where I was prompted for the "Upstream gateway" Since I did not get that option this time around, I have to go into the GUI and set it on the WAN.



  • Yes, on the console you should be asked for upstream gateway (or press return for none), and I thought that 2.1.5 had fairly nice questions for that.
    I know that in 2.2-RC it is certainly doing that all correctly from the console menus.



  • OK. I will log in via the GUI to the configure the WAN gateway setting and see what happens…I might also download another 2.15 version on another computer, install it in VirtualBox and see what prompts I get...



  • Phil, Followed your instructions, went into the GUI, set up the "upstream gateway" and now things are working fine…Thanks again for the advice...


Log in to reply