NUT



  • Hi,

    The NUT package in 1.2 does not install. Is it compatible with 1.2?

    Thanks,
    Sean



  • <looks at="" working="" nut="" package,="" installed="" on="" 1.2="" release="">Yup ;)  Maybe if you posted your errors?</looks>



  • Looks like something broke with 1.2 or a file is missing. I know NUT installed on 1.2 RC4 however I just deinstalled the package and reinstalled it on 1.2-RELEASE and it errors out.

    
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading nut and its dependencies... done.
    Checking for successful package installation... failed!
    
    Installation aborted.
    
    

    Unless this is an easy fix that I can do tonight I won't be able to look at it until after next week.



  • Well that is great. Take a look at

    ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/

    They removed the packages-6.2-release directory. I wonder how many other pfSense packages this affects as well. I know before we were using packages-6-stable, which is where the problem with nut appeared. The packages-6.3-release port does work and is different from the packages-6-stable port. We might just have to use that even though pfSense is using 6.2.

    Anybody have a copy of nut-2.0.4.tbz and nut-usb-2.0.4.tbz that I can just stick on the pfSense server for the meantime?



  • I can re-create the packages for nut-2.0.5_1 and nut-usb-2.0.5_1 (the wonders of pkg_create) for you, based on what's installed on my 1.2 release box.  If that's ok I'll arrange to upload them somewhere and PM you the location.



  • Same problem for me with FreeRadius. It does not install properly anymore.



  • @Cry:

    I can re-create the packages for nut-2.0.5_1 and nut-usb-2.0.5_1 (the wonders of pkg_create) for you, based on what's installed on my 1.2 release box.  If that's ok I'll arrange to upload them somewhere and PM you the location.

    I was able to find a copy of nut 2.0.4 on another mirror. My guess is it hasn't synced up with the freebsd mirror. I will upload the files and the package should be working in a few.



  • Same Here :( This is very bad it was working so good with 1.2 ,i just did a fresh install and now its not available  :-\

    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading nut and its dependencies... done.
    Checking for successful package installation... failed!
    
    Installation aborted.
    


  • I uploaded the files and made the changes to the pkg_config.xml file in the cvs but it did not sync to the web server. Sullrich if you have the time could you look into this. I won't have access to a computer this week.

    To Others:
    The issue is not a package compatibility with 1.2. Like I stated above the port package was removed from the FreeBSD server and thus it can't install.

    Please don't send me email asking how to install NUT or why it does not work. It will work fine once the pkg_config.xml is sync'ed.



  • @rsw686:

    I uploaded the files and made the changes to the pkg_config.xml file in the cvs but it did not sync to the web server. Sullrich if you have the time could you look into this. I won't have access to a computer this week.

    To Others:
    The issue is not a package compatibility with 1.2. Like I stated above the port package was removed from the FreeBSD server and thus it can't install.

    Please don't send me email asking how to install NUT or why it does not work. It will work fine once the pkg_config.xml is sync'ed.

    Thanks



  • @rsw686:

    … made the changes to the pkg_config.xml file in the cvs but it did not sync to the web server. Sullrich if you have the time could you look into this....

    So will this be fixed 'behind the scenes' or do I need to take out a new download via a CVS to make it work?

    Best regards
    Fribert



  • Any news on this Package ?
    It´s still not installing same thing

    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading nut and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.



  • Please see the half dozen or more other threads discussing package problems  ::)



  • Yes, but i was expecting this since the beginning of the week

    It will work fine once the pkg_config.xml is sync'ed.

    I also read on the blog there was a server migrating don't know if this could be the cause



  • This Package is back online, but once you install it when you go to NUT menu e get this message on the browser page :

    Warning: main(guiconfig.inc) [function.main]: failed to open stream: No such file or directory in /usr/local/www/pfswww/packages/config/nut/status_nut.php on line 31

    Fatal error: main() [function.require]: Failed opening required 'guiconfig.inc' (include_path='.:/usr/local/share/pear') in /usr/local/www/pfswww/packages/config/nut/status_nut.php on line 31



  • same type of error that the snort package is getting.

    I'm no expert on how pfsense is installing these packages but from looking at snort.xml I'm guessing that it downloads the php page from http://www.pfsense.com/config/$packagename/$pagewanted
    and sticks it in /usr/local/www. If that is the case and I'm sure someone will correct me if I'm wrong then the page it displays with the errors on is actually a page it has downloaded and not an error generated on the local pfsense box, or in plain english the box is fine it's just downloaded a error page and not the correct php page.



  • Nut Packadge BAck online Working Fine :)


Locked