I can't even install it…



  • Graid disk raid/r0 (comprising of ada0 and ada1 in a mirror) isn't presented during the install.
    Any attempt to install to ada0 or ada1 fails with an error stating that the paths don't exist (fails at "/sbin/bsdlabel -B -r -w ada0s1 auto" after setting the boot sectors).

    However… I just installed FreeBSD10.1 without any issue.

    Do I need to enable something prior to the install at the bootloader screen ?


  • Rebel Alliance Developer Netgate

    Do you mean "GEOM" or gmirror RAID?

    Installing to a GEOM mirror worked fine last time I tried it. Though I let the installer create the mirror.



  • Sorry… Let me clarify.
    (I apologize for any lack of knowledge... Primarily a Wintel/Ubu person)

    The motherboard is a Supermicro X9SCi with hardware assisted RAID.
    The mirrored array is configured in the bios consisting of 2x 120GB SSDs.

    Using graid via the shell raid/r0 is viewable.  However the installation to disk doesn't list raid/r0 as a destination.
    Only ada0 and 1 are shown but operations to these drives fail when labeling slices (as expected).
    Any attempt to modify ada0 or 1 via the shell fail with operation not permitted whereas raid/r0 is fine.

    However... I've been able to install FreeBSD 10.1 without issue.



  • I'll remove the mirror in the bios and try with the installer creating it.



  • Wow… Yup back to basics worked.

    Don't use the bios created array.  Delete it and let PFSense setup GEOM.

    Thanks


  • Banned

    Why would you do that? Hardware RAID is preferable to software RAID.

    This is exactly why I run this in ESXi on a RAID10….


  • Banned

    @Supermule:

    Why would you do that? Hardware RAID is preferable to software RAID.

    Huge -1. So called "HW RAID" is just an immense PITA when the RAID card or the MB dies. (If that's integrated on-board, there's nothing HW about it anyway.)



  • Yeah… hardware raid is always preferable to software.

    However, this hardware assisted raid based on the Intel® C204 PCH chipset works via AHCI and I believe that could be why I'm experiencing issues.
    It worked fine with 2.1.5 and with FreeBSD 10.1... but the array wasn't presented during the installation of 2.2.

    And yeah... I also run ESXi on RAID10 with the iscsi stores on a dual HA system setup also using RAID10.

    NOTE:- Interestingly... the drives ada0, ada1 and r0 are detected.  Just r0 isn't listed as a install destination.

    Additionally... hardware assisted is pretty much software raid.  Its still offloaded to the cpu... just the assisted version does it a layer above the os.



  • @JamesJohnson:

    Yeah… hardware raid is always preferable to software.

    Absolutely not! It depends on the requirements, budget and probably a few more parameters which solution is preferable. In addition, all stuff marketed as HW RAID are not equal. Some of it may not really even be that much HW, which have already been pointed out here.

    It's bad generalizations like the one above that make many uninformed people use solutions that may not always be the best for them. :(

    Software RAID may often be preferable for (at least) home and SOHO users as it is low cost and have good enough performance on the networks that can be afforded. Also not being dependant on proprietary HW is probably of value to some people. Maybe even more so in a forum like this one, dedicated to an open source solution…


  • Rebel Alliance Developer Netgate

    Hardware RAID is good if it is true full-hardware RAID and the controller is fully supported, but it all has to be managed by hand. Though it is more robust. A disk failure on hardware RAID may not cause problems with the system the same way that a hardware disk problem could cause them if they were directly attached, but that's all a crap shoot.

    Software RAID is "good enough" for most deployments, it's supported in the installer, and in 2.2 there's a management GUI for adding/replacing drives even.

    What sucks is crappy fake RAID that's really software/drivers with a little stub of hardware support to arrange the disks. That's not worth anyone's time.


Log in to reply