Squid + HTTP Error 417 Solution



  • We've had trouble with Squid interfering with communications with different vendors (HH2, Labtech, etc.) that would produce an HTTP 417 error and had difficulty finding the appropriate resolution so I thought I would post it here.

    Navigate to Services -> Proxy Server
    In the "Custom Options" field add "ignore_expect_100 on" (without quotes).
    Save and restart.

    It's worked for us and I hope it helps someone else along the way.


Log in to reply