Huawei E173s-3 only works after "restart webConfigurator"



  • hi all

    i managed to make a huawei E173s-3 work using the init string below (which according to http://www.3g-modem-wiki.com/page/Huawei+AT-commands means that it will disable the fake cd and sd reader, working only as modem)…

    ^U2DIAG=0
    

    but for some reason it only works after selecting "restart webConfigurator" at the console
    right after saving this init string the webGUI seems pretty slow too, that's why i restarted it the first time… then i realized in tests that it always worked right after restarting the webGUI... that doesn't make much sense to me, but that's what it seems to be the case

    anyone got any clues about why this is happening or how to solve this?

    ps: yeah, i know that i should post some logs to help you guys, but i just dont know which one =p

    The information below is just to help if anyone is searching for my old error, so they'll see this post and try using the init string above

    without this init string i only got the message below in the ppp logs:

    
    Jan 12 14:05:06	ppp: [opt1_link0] Link: reconnection attempt 283
    Jan 12 14:05:06	ppp: [opt1_link0] CHAT: +CGDCONT=1,"IP","gprs.oi.com.br"
    Jan 12 14:05:06	ppp: [opt1_link0] CHAT: Detected Hayes compatible modem.
    Jan 12 14:05:06	ppp: [opt1_link0] CHAT: The modem responded with "ERROR" to the command "AT&F&C1&D2E0S0=0M1" at ModemCmd: label.
    Jan 12 14:05:06	ppp: [opt1_link0] MODEM: chat script failed
    Jan 12 14:05:06	ppp: [opt1_link0] Link: DOWN event
    Jan 12 14:05:06	ppp: [opt1_link0] LCP: Down event
    
    

    and the modem disconnected right away

    dmesg:

    
    ugen3.2: <huawei>at usbus3
    umodem0: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus3
    umodem0: data interface 0, has no CM over data, has no break
    umodem1: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus3
    umodem1: data interface 1, has no CM over data, has no break
    umodem2: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus3
    umodem2: data interface 2, has no CM over data, has no break
    ng0: changing name to 'ppp0'
    ugen3.2: <huawei>at usbus3 (disconnected)
    umodem0: at uhub3, port2, addr 2 (disconnected)
    umodem1: at uhub3, port2, addr 2 (disconnected)
    umodem2: at uhub3, port2, addr 2 (disconnected)</huawei></huawei></huawei></huawei></huawei> 
    

Log in to reply