Freeradius install problems, attempt a manual pkg_add?



  • So I installed pfsense 1.2 on an x86 box (pentium III to be exact) with a HD install and settings for development (I figured if I needed to add packages, maybe that would be best).

    Not too long after this I set up all my interfaces (Lan0, Wan0) and got everything up and running. Afterwards I installed squid, squidguard, and snort directly from a web interface and everything went in without a hitch. Then I tried to install freeradius and kept getting the same error:

    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading freeradius and its dependencies... done.
    Checking for successful package installation... failed!

    This looked pretty familiar as there were others on this forum who posted having this same problem with this same package (in fact there were supposedly attachments detailing how to manually install it but I could not find the attachments!). Not wanting to waste anyone's time I've spent additional time by myself trying to get this to work, and managed to try and force an install myself. I got on the machine in question and did whoami to make sure I was logged in as root, and then after verifying this I tried pkg_install -r freeradius

    The output I get from that tells me I'm unable to get the file from the FTP server. Just for fun, I tried installing something which had previously worked (squid) and get the same error for squid!

    My question now is why can't I install from the command line and is there a way to point the install to a package available "offline" (like on a usb drive). If so, does anyone have a freeradius package already ready that I could get? I'm not so great at making these types of things yet, and my only OSes are WinXP and Fedora, and I've just started out with Fedora. If not, how am I supposed to go about making a FreeBSD package on Fedora (my guess is I probably cant...).

    Thanks in advance for your time.



  • Still really need this radius…

    Does anybody have an offline copy of the last working package that I could install manually?



  • I take it you missed the few dozen threads that mentioned why package installations were failing  ;)

    You probably also want to see http://blog.pfsense.org/?p=180



  • Oh jeez, sorry! I totally spaced on that. I shouldn't go away for a week and then not expect things to change :D

    Novice mistake, which I guess makes sense because I'm a novice when it comes to open source.

    By the way, speaking of hosting, I would click a donate button if you had a paypal link on the site… this isn't the right place to put that suggestion though so I'll find that place later.

    Anyways, FreeRadius works now!

    Time to tear this thing wide open...


Locked