Connecting to the WebGUI



  • Hello,

    This is my first post here (I'm a Gold Member)

    I have configured pfSense for ESXi for the first time.

    Everything is going well, but I can't connect to the WebGUi from the WAN interface. However,  can connect from the LAN interface.

    Can someone help?

    Cheers

    Carlton





  • I guess stating I'm a Gold Member doesn't go down very well here ….



  • See - The thing is thats very normal default behavior.

    If you wish to connect from the wan side to the web gui, I suggest you allow SSH on the WAN and proxy in and use proxy settings on your browser.

    Or set up openvpn and VPN in.

    Forwarding ports from the wan to allow GUI access directly isn't recommended (by me anyway)

    I suspect no one felt like answering this question for the millionth time is why no one has replied yet.

    Contrary to your initial feeling, I'm glad some people are gold members.  I assume it helps support the project.  (-:


  • Netgate Administrator

    @cpatte7372:

    I guess stating I'm a Gold Member doesn't go down very well here ….

    Not true.

    Personally I didn't reply earlier because, although it was a bit abrupt, KOM's post pretty much completely answered your question.

    Please ask further questions if you have any.  :)

    Steve



  • Apologies for my terse reply.  I help here for free during business hours, and my employer might have a bit of an issue with me spending time helping others here on their dime.



  • kej,

    If you wish to connect from the wan side to the web gui, I suggest you allow SSH on the WAN and proxy in and use proxy settings on your browser.

    Can you show me please?



  • Probably best way to go and fairly easy is to set up a openvpn server on pfsense.  Its well documented - search that.

    Tunnel all connections for simplicity.

    Export a client configuration to a laptop.

    Install it on the laptop and connect.

    Once connected, type in the same LAN IP you always type to access your gui.

    You are done.

    That is a fairly powerful and useful tool that you can then use for general security purposes.



  • Hello Kej

    I followed your suggestion from another post, but when I tried to log with addresss https://192.168.1.1/ nothing happened…


  • LAYER 8 Netgate

    https://your_public_ip_address/  Not 192.168.1.1  You can get your public IP in Status > Interfaces, WAN.


  • Netgate Administrator

    If you are connected via a VPN then using the LAN IP should work though. (firewall rules allowing)

    Back to basics; why are you trying to connect to the webgui from the WAN? It's not something that is usually done hence it's not enabled by default. What network configuration are you installing pfSense into?

    Steve



  • Errrrrr….  It works - Its just not smart.
    I killed my vpn connection before I tested it.

    VPN would DEFINITELY be the smart way to do it though.

    There is something amis.  LAN IP?



  • @stephenw10:

    why are you trying to connect to the webgui from the WAN? It's not something that is usually done hence it's not enabled by default.

    Steve

    I would just like to see it work


  • LAYER 8 Netgate

    Post your WAN firewall rules.  It works fine if you configure it correctly.


Log in to reply