Squid+squidguard+nat no forwading internal IP



  • Hi,
    I was wondering checking the firewall external, why the internal ip is seen in the check and not the external ip. What is the mistake. My aim is, that the wan-adress given by the router of my privider and the local IP of the client should be seen. The external IP should be the result.

    for example: Test your firewall via http://www.pcflank.com/

    Client uses the pfsense proxy to surf.
    pfsense proxy uses squidguard to filter and delivers the result.
    The IP who asks for the fqdn schould be the pfsense prox server. The server should forward its own ip or better the external IP.

    In which way can this be build?

    thnx



  • this may help

    check the following:

    Disable X-Forward
    Disable VIA
    Suppress Squid Version



  • Thanx 4 the tip. It helped.

    smile


Log in to reply