[solved] pfsense 2.2 rc turkish rule apply problem



  • problem 1: When i tried to turn from english to turkish and from turkish to english, suddenly my computer, which was connected to firewall, could not connect to internet except my firewall. I loaded the last back up but at this time, firewall could not be started after restarting. There was no error message on the monitor. I reset the firewall with its starting button and it fixed.

    Problem2:

    https://redmine.pfsense.org/issues/3886 bug don't solved.

    English: Firewall >> Rules >>  Lan  or WAN >>  + (Add)  >>  Save


    Turkish

    Firewall >> Rules >>  Lan  or WAN >>  + (Add)  >>  Save

    dont Apply. rule does not work, maybe run… usually does not work ..



  • At least with portuguese languange, it does not work since 2.1



  • So https://redmine.pfsense.org/issues/3886

    Renato Botelho:

    Done. We will have a new translation server available soon to make users able to translate again.

    There are no translation server to.



  • The problem you have is that there is no Apply button even displayed, and thus you have no hope to be able to implement the changes. That is a bit different issue to the translation of the text not being there - and I can see it is a real painful bug.
    Actually that can be fixed to ensure the Apply button is displayed regardless of whether the translation to Turkish/Portuguese… succeeds.
    Proposed fix: https://github.com/pfsense/pfsense/pull/1441

    I also shuffled the way it builds the text translation string so that "You must apply the changes in order for them to take effect." now at least comes out in Turkish.

    There is a general issue here also - the availability of the Apply button in many places should not be dependent on various bits of different translations all succeeding and matching up.

    Hmmm - I am starting to get more comfortable with the Turkish menus  8)

    Edit: pull request is merged, so should be fixed in a new snapshot.



  • @phil.davis:

    The problem you have is that there is no Apply button even displayed, and thus you have no hope to be able to implement the changes. That is a bit different issue to the translation of the text not being there - and I can see it is a real painful bug.
    Actually that can be fixed to ensure the Apply button is displayed regardless of whether the translation to Turkish/Portuguese… succeeds.
    Proposed fix: https://github.com/pfsense/pfsense/pull/1441

    I also shuffled the way it builds the text translation string so that "You must apply the changes in order for them to take effect." now at least comes out in Turkish.

    There is a general issue here also - the availability of the Apply button in many places should not be dependent on various bits of different translations all succeeding and matching up.

    Hmmm - I am starting to get more comfortable with the Turkish menus  8)

    Edit: pull request is merged, so should be fixed in a new snapshot.

    That news perfect :) thank you for interest. Now we waiting new translation server.



  • @phil.davis

    thank you…..

    best regards



  • @phil.davis

    thank you….. +1



  • No problem. I might have a bit of fun with some Nepali translation some day - a language based on a  completely different script might be a fun way to mess up all the displays  ;)
    Let me know if you find other places where things go wrong. I suspect there are other places where the Apply button will not display if the language translation work is only part complete.
    In a few days I will have a go at standardizing that code better - of course any further changes like that will end up in 2.2.1 or later… but should be easy to GitSync or apply with System Patches for those who care about the language selections.


Log in to reply